Can Upfront be fixed to not require rewrite

I loaded the fixer theme today as a starting point for a new site I'm setting up (darkhollowinternet.com). I saw several issues that all seem to stem from fixer/upfront requiring rewrites be enabled. Due to historical issues, I've kept them off so it caused two issues for me:

1) Homepage failed to display background image
2) When trying to change background image elements in editor, it doesn't load properly and shows the dialog at the bottom of the page with poor styling.

Both of these issues appear to stem from the use of the /upfront-dependancies fake directory (url is http://darkhollowinternet.com/upfront-dependencies/styles/d25703bb5ae070246833b909ebe61d60?ver=0.1.2).

It appears that this is similar to the issues seen by kendavis in https://premium.wpmudev.org/forums/topic/problems-with-upfront-and-spirit-template . The solution of adding AllowOverride All is a bit excessive and not something that i want to use. AllowOverwrite FileInfo allows the redirectengine to work which solved the problem temporarily but I would prefer to not require usage of the .htaccess file or allow any overrides in the web directories.

  • Tyler Postle

    Hey Modperlman,

    Thanks for your feedback here. I'll pass that on to our Upfront developers.

    As for your issues, if you do add the AllowOverride solution does it resolve your issues? I know you don't want to keep it there but just want to make sure that is the issue in this case.

    Which host are you on? Some members on GoDaddy have had issues with images not showing up due to their server side caching, that's an issue we're already looking into :slight_smile:

    Would you mind granting support access so we can see the issue first hand on your site?

    You can grant support access via admin dashboard - WPMU DEV > Support > Support Access > Grant Access.

    Look forward to hearing back on this!

    Cheers,
    Tyler

  • modperlman

    Tyler,

    I've been looking into it further and the issue isn't actually with fixer / upfront, it properly calls home_url but home_url() is not doing what is expected when domain mappings are in place.

    The domain mapping plugins (I was using wordpress-mu-domain-mapping and switched to the wpmu domain mapping plugin to test) put in a pre_option_home filter that overrides the value of the home_url and puts in the domain mapped url (wp-includes/options.php line 45 in 4.1.5). The home is set in the database to http://darkhollowinternet.com/index.php but the filter just returns the domain portion http://darkhollowinternet.com and so the upfront-dependencies link is not generated correctly.

    The blog is privately hosted on a linode instance. I think at this point, I'm probably fighting a losing battle of not using rewrite and I'm best to leave it enabled.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.