Can you help me get Cloner working properly?

I tried to clone a site (metz to namur) for the first time and it failed to compelte. I contacted WPEngine support and they found the following in the error logs:

WordPress database error Table 'wp_urldev.wp_3_icl_translations' doesn't exist for query SELECT t.*, tt.* FROM wp_3_terms AS t INNER JOIN wp_3_term_taxonomy AS tt ON t.term_id = tt.term_id LEFT JOIN wp_3_icl_translations icl_t ON icl_t.element_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category', 'post_tag', 'link_category', 'post_format', 'exponant-category', 'expo-categories', 'adgallery_post_cat', 'slide-page', 'portfolio-gallery') AND icl_t.language_code = 'fr' AND icl_t.element_type IN('tax_category','tax_post_tag') ORDER BY t.name ASC /* From [namur.urldev.net/wp-…ev.net/wp-admin/admin-ajax.php] in [/nas/wp/www/cluster-3157/urldev/wp-content/plugins/cloner/copier/class.copier-terms.php:25]

WordPress database error Table 'wp_urldev.wp_3_icl_strings' doesn't exist for query \r\n SELECT s.name, s.value, t.value AS translation_value, t.status\r\n FROM wp_3_icl_strings s\r\n LEFT JOIN wp_3_icl_string_translations t ON s.id = t.string_id\r\n WHERE s.context = 'plugin cloner'\r\n

10:18 am and:

PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, class 'WPMUDEV_Cloner' does not have a method 'add_blogname_suffix' in /nas/wp/www/cluster-3157/urldev/wp-includes/plugin.php on line 470, referer: http://namur.urldev.net/wp-admin/

  • Patrick
    • Support Monkey

    Hi there @bchamberlain57

    Welcome to the forums, glad to have you aboard!

    Hmm, I just tested the latest version of Cloner (1.2) on both subdirectory and subdomain test networks, and it completed with no errors on both tests.

    I'm not quite sure what to make of the errors you report myself, so I'll see if another support staff member can jump in here to lend a hand.

  • Michael Bissett
    • Recruit

    Hey @bchamberlain57, thanks for your patience here! :slight_smile:

    A few questions, if I may:

    - Does this only take place when you try to run the cloning process between these particular sites? Are they both sub-sites?

    - Does this only show up when you're trying to replace a site via cloning?

    - Have you tried going through the cloning process on the staging site?

    - On a side note, I just went to your site, and it came up blank for me, are you having troubles with your hosting presently?

    Please advise,
    Michael

  • Michael Bissett
    • Recruit

    Hey @bchamberlain57,

    While it's unfortunate that you ended up having to go with a different solution, it's good to hear that you were able to get the results you needed in the end. :slight_smile:

    If you'd ever like for us to look into this error again, please feel free to ask, as we'd be more than glad to get this taken care of.

    Hope you're doing well today, and thanks for being a member here! :slight_smile:

    Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.