Can you please make this compatible with Single Installation?!

Or how can I make it compatible?

I have a buddypress install and would love this for my network. Thank you!