Can´t enable domain mapping

Hi,
I can´t enable domain mapping. I added the sunrise line to the config file, the sunrise file to the root and the domain-mapping.php to the mu-plugin folder ( I also try with the norma plugin folder) No options appear under settings, tools, nowhere in network admin or site admin. What can I do?

  • DavidM
    • DEV MAN’s Mascot

    Hi akupf,

    Assuming you've got the main plugin file in the proper place in the mu-plugins folder you should definitely see some settings. To clarify, the main Domain Mapping plugin file should reside in the following:
    wp-content/mu-plugins/domain-mapping.php

    Could you please verify that's there?

    With that in place, you should then see the plugin in your Network Admin plugins Must-use list.

    You should also see some options for the plugin at Network Admin -> Settings > Settings, right toward the bottom of the page of options.

    Could you please let us know if you see all these things?

    Thanks,
    David

  • akupf
    • New Recruit

    Hi!

    I have the define('SUNRISE','on'); in config:

    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    */
    define('WP_DEBUG', false);

    define('SUNRISE','on');

    /* That's all, stop editing! Happy blogging. */

    I also have sunrise in content and domain-mapping in plugin-mu

    But still can´t see it under settings or must see (here I only see supporter)

  • DavidM
    • DEV MAN’s Mascot

    Hi akupf,

    I'm not sure if that was a typo, but the plugin shouldn't be in /plugin-mu/, but in /mu-plugins/.

    Just to confirm though, do you have the file domain-mapping.php in exactly the same folder as the supporter-framework.php file?

    The two should be in the same folder. It definitely seems that is the issue since the plugin isn't showing in your Must-use plugins list. Could you please verify that?

    Thanks,
    David

  • akupf
    • New Recruit

    Hi again!
    I tried this time with a different site. Now I can see the plugin option in the admin. But when I try to setup the server IP, hit save and get this message:
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/7/d219580247/htdocs/alquilernoubarris.com/wp-config.php:1) in /homepages/7/d219580247/htdocs/alquilernoubarris.com/wp-includes/pluggable.php on line 897

    Any ideas?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.