Cancel my subscription early - Stopped me getting my 30 days worth of support!

Hi,

After recently purchased market press and being disappointed with it's performance in theme graphene I wanted to make sure I cancel the re-occuring part of my subscription but keep my 30 days THAT I'VE PAID FOR! however the system has stopped me from doing this.

Could someone please help?

Cheers

Martin

  • Philip John
    • DEV MAN’s Apprentice

    Martin,

    I can see that you joined us yesterday and subsequently cancelled your membership.

    I can also see that you still have access the service until September 9.

    In fact, if the system has stopped you from accessing our services you wouldn't have been able to post this thread.

    Having looked at your profile I can also see that you haven't yet taken advantage of the support that forms part of your membership fee. If you're having issues with using MarketPress please start a new thread where we'll happily look into those issues for you.

    Thanks!
    Phil

  • exceedcoaching
    • WPMU DEV Initiate

    Hi Phil,

    thanks for your offer of support.

    My problem is getting MarketPress to work correctly graphene them. I tried a few different carts and they all seem to struggle looking correct with graphene.

    I'm not sure what I could send you to best evidence the issues. Basically it doesn't set up cart pages, your account pages correctly, it pulls through weird pages like the 'About' page when you go through to the cart. Also the { product page] is written in the drop menu like that instead of link to a page.

    Any ideas? Or let me know where is the best place to start in getting you clearer information as I understand this information is a little vague.

  • Eric G.
    • The Crimson Coder

    I agree. I would use your time you have left here to get the support first. These guys can typically help you get it working. You may have to put the pressure on.

    To answer your question though. There is a 'cancel at anytime' link at the bottom of the page.

  • Philip John
    • DEV MAN’s Apprentice

    My assumption is that your Graphene settings should remain. They should simply be stored in the database and unless Graphene removes that data upon de-activation (unlikely) your settings should still remain when you re-activate.

    No promises of course but I'd be surprised if you lost your settings. Easiest thing would be to take a backup of the wp_options table that you could restore easily.

    Phil

  • Philip John
    • DEV MAN’s Apprentice

    Okay, it looks like your hosting package isn't up to the task of hosting WordPress.

    Can you check what the memory (not storage) limits are on your hosting package? If you're not sure, ask their support and see if you can get an increase.

    Thanks,
    Phil

  • exceedcoaching
    • WPMU DEV Initiate

    Hi Phil,

    The stats I got automatically today was

    Disk Usage (which I know is storage) 63mb of 250mb
    Bandwidth (which I people is more about the amount of traffic that can flow through) 401mb of 20,480

    Pretty certain these aren't what you are looking for so I'll log-on tomorrow when their live support is online and ask.

    Cheers for the continued help, it is really appreciated.

    Martin

  • Jonathan
    • The Incredible Code Injector

    @exceedcoaching,

    You're in good hands with Phil, he is super cool, and extremely knowledgeable. And just reading his statement that your "hosting package isn't up to the task of hosting WordPress". I'm afraid I think he is right.

    Even though you haven't given how much memory you have at your disposal. I can tell you that 250mb storage, and 20gig bandwidth is what would be termed "below entry level" more for html only sites, and not suited for cms (content management systems) like wordpress etc.

    I generally don't recommend shared hosting, but any shared hosting package will give you better performance than your current hosting package and probably for the same price.

    Don't feel bad. In my country South Africa your type of hosting packages are common place :wink:

    But I'm hoping that the figures you gave are a typo, but for a site that intends on running a online shopping ecommerce business it falls well below entry level :slight_frown:

  • Philip John
    • DEV MAN’s Apprentice

    Thanks Jonathan :slight_smile:

    Yep, that's right - that's a very low level for a hosting package and I suspect your memory (i.e. the RAM available) is equally low and hence isn't enough for WordPress.

    You should have at least 128MB RAM available to you ideally. If you don't have that I would consider upgrading your current host or seeking out a new one.

    Phil

  • exceedcoaching
    • WPMU DEV Initiate

    Morning Phil/Jonathan

    Am not surprised the hosting isn't amazing it's free. I hadn't planned initially to put e-commerce on the site.

    Just spoke to them and the memory is set at 32mb. I can increase this at no charge as long as it doesn't cause stability issues. Which I'd be surprised if it does because the site is very low volume.
    What size do you think I should request?

    And yes Jonathan I completely agree Phil is amazing!

  • Jonathan
    • The Incredible Code Injector

    @exceedcoaching,
    The 500 Internal Server Error is a server-side error which means something is broken on your server - and the best way to find out would be to check your error logs.
    This error happens a lot :wink: It's a pain, but the good news is the error logs usually paint a picture of what's happend. Bad news is your free account doesn't give you access to those error logs.

    This is what your hosting company considers:

    as long as it doesn't cause stability issues

    So you are stuck between a rock and a hard place. shrugs. You need those error logs in order to identify what triggered it... and you need to do it in such a way as not to step on the hosting companies toes. The joys of free hosting.

    Perhaps phil can guess as to what the error could be. But I'll most probably miss the target (issue) as I'll be shooting blind.

  • exceedcoaching
    • WPMU DEV Initiate

    No idea how they changed the memory limit. I sent a requested they email back and said it had been done.

    Do I need to go in and have a snoop around these files to look for something in particular. I use Filezilla as a FTP service which allows me to quick check permissions, if that is a issue?

  • Philip John
    • DEV MAN’s Apprentice

    It's unlikely to be permissions. If the hosts themselves did it then I'd leave it to them to figure it out.

    Make sure you give them URLs to show the pages that are giving 500 errors. That'll prompt them to check themselves when they revisit the edit.

    Phil

  • exceedcoaching
    • WPMU DEV Initiate

    Hi Phil,

    steps I've taken today -

    Deleted old install and put fresh install on
    updated to most recent market press
    (didn't fix the 500 error!)
    Deleted all the old product tests -cat,tags,etc
    (No more 500 error)
    I've not managed to get back the very original error I had when I first installed market press and wanted help!
    Which is -

    http://johnsframingservice.co.uk/store/products/
    ERROR: You must supply the post ID to get the image from as an argument when calling the graphene_get_post_image() function.

  • Moonworks
    • Code Wrangler

    I'm seeing that original error of yours showing up on the products page.

    I thought I'd let you know about the host I use in the UK, Tagadab. They know what they are doing and are always able to help with any problems by phone or email. More importantly for you though, is they have a trial for just £1, so you can see if it is just what you are after.

    This is their basic package:
    http://www.tagadab.com/uk/virtual-private-servers/VPS_250

    I should point out though, that there are many services out there, some cheaper than this, but this is the best I've come across and have never had a problem that wasn't solved quickly in over 2 years of being with them.

  • Mark de Scande
    • Syntax Hero

    The Fix for your problem is easy :slight_smile: first of i dont know code but i can read

    Go to this page
    http://johnsframingservice.co.uk/store/products/

    Products
    ERROR: You must supply the post ID to get the image from as an argument when calling the graphene_get_post_image() function.

    test product listing pageTest Product 1Test excerpt More Info »Price: £5.00
    test product listing page

    SO it is telling me to go to "page.php" and just remove the function that is calling graphene_get_post_image() function. This will then make the page work.

    The shopping cart system seems to be working fine you only have to remove the code at the top of the page and then the err will go away :slight_smile:

    PS I am also from South Africa :slight_smile:

  • Philip John
    • DEV MAN’s Apprentice

    My term of fresh install is not as good as yours! No I simply did a de-activate and a delete files.

    If you want to do a completely fresh installed (i.e. remove all data such as content and settings) you'll want to delete all the tables from the database.

    Do a backup first if you do end up doing that...

    Phil

  • Mark de Scande
    • Syntax Hero

    Here is my advice on the problem use it dont use it remember i am not a coder but i have been using WP on my own dedicated server for a long time

    First off your your host and file permissions

    as him to SSH in to the box and run the following commands for you

    chmod -R 777 /home/accountname/public_html/
    chmod -R 777 /home/accountname/public_html/wp-content
    chown -R accountname:accountname /home/accountname/public_html/

    Then use ftp and upload the file to your server

    Now ask him again to run

    chmod -R 777 /home/accountname/public_html/
    chmod -R 777 /home/accountname/public_html/wp-content
    chown -R accountname:accountname /home/accountname/public_html/

    IF he cant run this command change your host :slight_smile:

    Now start over set up the shopping cart most of the setting should still be there

    Now go to the front page and test the shopping cart if all is working then well dont if not post the err here i know the guys will help you out

    I hope this helps

    If not let me know and i will set up a test account on my box and you can play with it on my server as i know it will work .

    Again i am not trying to make money from you in any way i am just trying to help you out .

  • exceedcoaching
    • WPMU DEV Initiate

    @Mark de Scande thanks for the support, it is appreciated. It's just Phil has been following this through for a few days now so I'd like to keep the continuity we've got.

    Hi phil,

    Here is a screen print of the product page- (First time upload of image size right! I must be getting good at this!)

  • exceedcoaching
    • WPMU DEV Initiate

    I'm not sure if it helps, I've discovered the coding that causes this error, although I wouldn't have clue how or if it needs changing -

    * This function gets the first image (as ordered in the post's media gallery) attached to
    * the current post. It outputs the complete <img> tag, with height and width attributes.
    * The function returns the thumbnail of the original image, linked to the post's
    * permalink. Returns FALSE if the current post has no image.
    *
    * This function requires the post ID to get the image from to be supplied as the
    * argument. If no post ID is supplied, it outputs an error message. An optional argument
    * size can be used to determine the size of the image to be used.
    *
    * Based on code snippets by John Crenshaw
    * (http://www.rlmseo.com/blog/get-images-attached-to-post/)
    *
    * @package WordPress
    * @subpackage Graphene
    * @since Graphene 1.1
    */
    if (!function_exists('graphene_get_post_image')) :
    function graphene_get_post_image($post_id = NULL, $size = 'thumbnail', $context = '', $urlonly = false){

    /* Display error message if no post ID is supplied */
    if ($post_id == NULL){
    _e('ERROR: You must supply the post ID to get the image from as an argument when calling the graphene_get_post_image() function.', 'graphene');
    return;
    }

    /* Get the images */
    $images = get_children(array(
    'post_type' => 'attachment',
    'post_mime_type' => 'image',
    'post_parent' => $post_id,
    'orderby' => 'menu_order',
    'order' => 'ASC',
    'numberposts' => 1,
    ), ARRAY_A);

    $html = '';

    /* Returns generic image if there is no image to show */
    if (empty($images) && $context != 'excerpt' && !$urlonly) {
    $html .= apply_filters('graphene_generic_slider_img', '<img alt="" src="'.get_template_directory_uri().'/images/img_slider_generic.png" />');
    }

    /* Build the <img> tag if there is an image */
    foreach ($images as $image){
    if (!$urlonly) {
    if ($context == 'excerpt') {$html .= '<div class="excerpt-thumb">';};
    $html .= '';
    $html .= wp_get_attachment_image($image['ID'], $size);
    $html .= '
    ';
    if ($context == 'excerpt') {$html .= '</div>';};
    } else {
    $html = wp_get_attachment_image_src($image['ID'], $size);
    }
    }

    /* Returns the image HTMl */
    return $html;
    }
    endif;

  • Philip John
    • DEV MAN’s Apprentice

    Okay, as I thought your theme is basically interfering with the output of MarketPress for some reason.

    Do you have support for that theme? It's definitely a theme issue so hard for us to look into because it's unfamiliar code. If you can show this thread to Graphene's author that would help them to figure out why it's stopping MarketPress do it's thing and fix it though.

    Phil

  • Mark de Scande
    • Syntax Hero

    I have tested the shopping cart and theme "graphene" on bloglines.co.za and i get the same err you got i then tested it with about 50 themes and it worked out the box the problem is the theme.

    Sorry for the bad news but pick one of wpmudev theme and then try the shopping cart again

    Ps @wpmu I have played with ---- Shopping cart for years now and trust me when i say your shopping cart worked out the box not like ---- that you have to spend a week to get working as it take over the whole WP all i can say is i need a gate way for the SA Market :slight_smile: but that's a new post Thank you again grate work on your shopping system

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.