CANCEL not working in emails (html)

All the other shortcodes work fine apart from CANCEL.

Allow client cancel own appointments is set to Yes but it doesn't appear to make a difference.

Login is not required.

  • Rupok

    Hi Federico,

    So sorry for the inconvenience you are having. I could regenerate this on my test site also. So I'm marking this as a confirmed bug and reporting to our developer right now. I believe, he will come up with a solution soon.

    Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and release a fix. I appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Panos

    Hi Federico ,

    Until this feature is fixed you can try out a mu-plugin I prepared and attached here.

    You can download file, unzip and upload to your wp-content/mu-plugins folder (if you don't have a mu-plugin folder you can simply create one, or it can be installed/activated as a normal plugin ).

    After you upload file you will need to

    1. Create a new page and add the following shortcode:
    [app_cancel_page]
    This page will be used as the cancellation page where the user will be redirected from the email.

    2. Edit the file you uploaded and in line 45 add the id of the cancellation page you previously created:
    from $this->cancel_page = null;
    to eg $this->cancel_page = 432;
    where 432 is the id of the cancellation page

    3. Add the following in your wp-config.php file
    define( 'APP_ALLOW_CANCEL', true );

    4. Instead of the CANCEL placeholder use APP_RM_LINK

    If you feel that this is out of your comfort zone I would be happy to do this :slight_smile: You can admin and ftp access privately through our contact form : https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:Subject: "Attn: Panos Lyrakis"

    - Admin login:
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference: https://premium.wpmudev.org/forums/topic/cancel-not-working-in-emails-html

    Thanks!

  • Charles

    Hello,

    I have this same problem. Plugin version 2.0.2. I applied the fix above and client was taken to the page I created in step 1. But they're asked to log in to cancel. That shouldn't be, as the previous plugin version I used happily for a long time not only had the cancellation link in the email, there was no requirement to create any account or log in to book or cancel appointments.

    How can I remove this annoying need to log in to cancel appointments?

    Urgent resolution needed, please.

    ===

    Also, what happened to the shortcodes and their applicable parameters? There was a tab for that in the previous plugin version I used, but that's disappeared. Why remove such a useful feature?

  • Rupok

    Hi Charles,

    Sorry for the inconvenience and thanks for asking. I've already pinged our SLS guy regarding this. I believe, he will come up with his valuable feedback soon.

    As I said above, our SLS people work round the clock and they have to deal with lots of critical issues and other things. So it may take a little while for them to check this and provide a feedback.

    I appreciate your patience.

    Have a nice day. Cheers!
    Rupok

  • Panos

    Hey Charles,

    This check for user to be logged in has been added for better security, making sure no appointment will be removed if any one else uses this cancel link.

    Since this is a feature you need though I have attached the same mu-plugin with the user checked to be removed this time. In order to use you need to replace in line 45 the null with the id of your cancellation page in which you have inserted the [app_cancel_page] shortcode.

    As for the shortcodes list, there should be a dropdown on the wp-editor ( when editing the content of a page ) which includes a list with available shortcodes and their options appear when clicking on one.

    Please let us know if you have any issues if either the mu-plugin or shortcodes list.

    Thanks!

  • Charles

    Hi Panos,

    Thanks very much for the fix. The APP_RM_LINK code works fine in the confirmation email, but not in the reminder emails, It just shows the actual code instead of rendering the link. How can I make it work also in the reminder emails?

    Kind regards.

    PS. Thanks for clarifying the location of the shortcodes. Would be nice to have an info button within the applet or perhaps a tab in the plugin settings that explains the various options.

  • Charles

    Reminder email link still doesn't work!

    Only the confirmation email link works.

    With the previous file, the shortcode text was inserted into the reminder email, instead of the actual link.

    But now, neither the text nor the link shows.

    I upgraded to Appointments+ 2.0.3 just before testing the new file you sent. Any connection?

    One other thing, I noticed that on line 45, you already had a page id of 18605 instead of null as before. Of course I changed that to my actual page id.

  • Panos

    Hi Charles,

    I just tested it again on my test site and the cancel link was added. I tested with latest version 2.0.3

    I have added code here : https://gist.github.com/panoslyrakis/59d4e91c176f9ece823289ce5d6e9cd0

    All you need to do (except for instructions :slight_smile: ) is remove or comment out lines 101-112 and 117-119 so that it doesn't check if user is logged in.

    If it still doesn't work could you please send admin and ftp credentials so I can have a closer look? I have explained how to send this information here: https://premium.wpmudev.org/forums/topic/cancel-not-working-in-emails-html#post-1199451.

    I would also need to do some test appointments on your site in order to check the reminder, so please let me know if you are not OK with this

    Thanks!

  • Charles

    I followed your instructions to the letter, even replacing the file with the latest one provided, but the problem is the same.

    I've now given up on this as there is clearly a problem with the latest version of the plugin and I have neither the time nor inclination to fix it. That's a shame, really as the plugin was the only reason I decided to buy premium membership.

    The developers need to resolve the issue. The feature was working before, so whatever changed, this is the unintended consequence.

  • Panos

    Hi Charles ,

    As Kasia mentioned, there are plans of re-adding this feature.

    For now I would like to give another try on the workaround. As it seems to be working on my side, could you please provide admin and ftp access so I can do some tests and see what is happening?

    You can send access credentials privately through our contact form: https://premium.wpmudev.org/contact/#i-have-a-different-question

    Send in:Subject: "Attn: Panos Lyrakis"

    - Admin login:
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    - link back to this thread for reference

    I will create a test Provider and client to check the reminder emails being sent.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.