Can’t create a group after update

Something is wonky with BuddyPress after the last update.

Shortly after the update I created a new group called Bible Study Methods (http://biblestudymethods.ferrisbaptistfellowship.org/). This new group took a little time to finally start displaying. In fact I had to go into mysql to change the URL for the blog for it to start working. Now is displays the home page but it is missing the BuddyPress admin bar at the top. Plus, the navigation will only display the home page and nothing else.

I tried to create another group with a blog but it will not do it correctly. I can start the creating process by completing steps 1 & 2 but then it gets stuck. If I click on enable group blog, the only choice is create a new blog and none of the member options are changeable. The previous step and next step buttons are in a strange place dangling at the lower portion of the screen. If I complete the process here’s what happens:
It creates a group and a blog but the blog has no name in the Network admin section.
If you try to go to the blog it says there is a redirect loop.
I also just noticed that the new blog is not a subdomain (i.e. testing.ferrisbaptistfellowship.org) but rather it is ferrisbaptistfellowship.org/groups/testing/blog.

Is this some setting I have overlooked? Do you know how to fix this?

Thanks for your help.

Wendy

Info:
WordPress v. 3.2.1
WordPress is the root install of my shared hosting package with Hostgator
I was already running the current version of WordPress
Yes, everything was functioning correctly before the upgrade
BuddyPress v. 1.2.10
We were using BuddyPress v. 1.2.9 before the upgrade.
The plugins that are currently active on the domain are:
BuddyPress Announce Group
E-Newsletter
Social Profiles Widget
WordPress Amazon Associate
WP-Cycle
The plugins that are currently active on the network are:
Akismet
BackupBuddy
Biblefox for WordPress
BP Groupblog
BuddyPress
BuddyPress Badge
BuddyPress Classifieds
BUddyPress Mobile
BuddyPress Sitemap Generator
Flexi Pages Widget
Genesis Connect
Genesis Favicon uploader
Genesis Simple Edits
Genesis Simple Menus
Google Calendar Events
Membership Premium
Multisite User Management
Tiny MCE Advanced
WPMU DEV Update Notifications
Theme: Genesis theme with the GenesisBuddy Add-on
Have you modified the core files in any way? No
Do you have any custom functions in bp-custom.php? No
If running bbPress, which version? Or did your BuddyPress install come with a copy of bbPress built-in? We don’t use bbPress
Please provide a list of any errors in your server’s log files. My server Error Log file is empty
Hosting: Hostgator
Is your server running Windows, or if Linux; Apache, nginx or something else? Linux

  • DavidM
    • DEV MAN’s Mascot

    Hi WendyMerritt,

    Hmm, it really does sound like you might have a plugin conflicting with BuddyPress itself here, perhaps the theme too, it's hard to say.

    Any chance you could try switching to the BuddyPress default theme a quick moment to see if the same issue occurs?

    If so, the best route, I'd say, would have to be to try deactivating plugins one by one to see where there might be a conflict.

    Have you tried that already? If not, could you give that a go?

    Thanks,
    David

  • Wendy Merritt
    • WPMU DEV Initiate

    David,
    Thanks for the tips. Once I switched to the default theme I was able to create a group and attach an existing blog to it. Everything functioned perfectly. Afterwards, I just re-activated the theme and everything is good. Do I need to be concerned that the Genesis theme does this? Do you see any further ramifications down the road for this type of issue?

    Now I'm off to StudioPress to inform them of the the conflict with Genesis and GenesisConnect. I was a little annoyed to begin with that I had recently purchased Genesis Buddy to use the Genesis them with BuddyPress. Then they took the plugin over from the previous owner and I had to buy it again under their name of GenesisConnect. Not exactly good customer service if you ask me.

    Anywho, thank you for your help.

    Blessings,
    Wendy

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.