Cannot Access Network Admin

I have a multisite install with one subdomain. Honestly at this point I am not really sure when this occurred because it has been an issue for awhile. I can access the main site (1) and subdomain site (2) without any issue, and the site itself functions without issue, but I cannot access the Network Admin Dashboard. Most of the time it is just the white screen of death, but occasionally it will say "Sorry, you do not have permission to access" despite my user account obviously having admin privileges.

I have read other discussions on this topic. Tried disabling plugins, but nothing helps it. Nothing of significance shows up in the error_file. Any other place to look, or direction to go? Thanks.

  • James Morris

    Hello Don,

    I hope you are well today.

    In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • James Morris

    Hello Don,

    I hope you are well today. Thank you for sending me that information.

    I was able to login to your site and determine what is causing the problem. There seems to be a conflict with the Nellie theme. When I disabled this theme, your Network Admin Dashboard loaded successfully.

    I attempted to modify the theme to overcome the conflict, but I'm afraid I was unable to get it to work correctly. There seems to be a compound issue with this theme.

    You may want to contact the theme developer and reference the notes from this thread so that they will know there is an incompatibility with the latest version of WordPress.

    The error I was getting in debug.log that lead me to check this theme is as follows:

    [13-Jan-2017 08:20:02 UTC] PHP Fatal error: Call to undefined function get_current_screen() in /public_html/wp-admin/network/settings.php on line 24

    Essentially, the theme is calling get_current_screen() but doing so improperly, causing issues with the core WordPress files.

    I have left this theme activated for the time being until you can decide which direction you wish to go. In order to restore access to your Network Admin Dashboard, simply login to your server via FTP, access wp-content/themes/ and rename the Nellie folder. This will disable the theme and enable access to your dashboard.

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.