Cannot activate plugin

The ultimate Facebook-plugin will not activate due to ‘fatal error’:

Fatal error: Uncaught exception ‘Exception’ with message ‘Facebook needs the CURL PHP extension.’ in /home/vds/public_html/clients/client2/web16/web/wp-content/plugins/wpmu-dev-facebook/lib/external/base_facebook.php:19 Stack trace: #0 /home/vds/public_html/clients/client2/web16/web/wp-content/plugins/wpmu-dev-facebook/lib/external/facebook.php(18): require_once() #1 /home/vds/public_html/clients/client2/web16/web/wp-content/plugins/wpmu-dev-facebook/wpmu-dev-facebook.php(102): require_once(‘/home/vds/publi…’:wink: #2 /home/vds/public_html/clients/client2/web16/web/wp-admin/plugins.php(142): include(‘/home/vds/publi…’:wink: #3 /home/vds/public_html/clients/client2/web16/web/wp-admin/plugins.php(144): plugin_sandbox_scrape(‘wpmu-dev-facebo…’:wink: #4 {main} thrown in /home/vds/public_html/clients/client2/web16/web/wp-content/plugins/wpmu-dev-facebook/lib/external/base_facebook.php on line 19

How do I fix this?

  • James Dunn
    • The Crimson Coder

    Good day @theormondian.

    This Exception denotes that CURL is not installed/enabled on your hosting environment. It’s really quite a simple fix.

    If you are hosting with someone else, simply contact them and ask them to enable CURL. If they will not do it – change hosts. Sorry to be blunt there.

    If you are hosting on your own server, contact your server engineer and have them enable CURL.

    If you are hosting on your own server and you are the server engineer, then you know what to do – but you probably would not be asking this question if you were your own server engineer. :wink:

    Have a great Friday and post back to let us know this solved your issue OR to give additional information.

  • aecnu
    • WP Unicorn

    Greetings theormondian,

    Thank you for this great question and a significant item to bring up.

    JamesDunn is right on the money on this one. Your hosting platform does not have curl installed or not properly installed.

    If you are hosting this yourself please recompile Apache to include the curl extensions.

    If you are not hosting this yourself please contact the host and request that they recompile Apache to include the Curl module.

    Thank you both for being WPMU Dev Community Members!

    Cheers, Joe

  • James Dunn
    • The Crimson Coder

    Thanks Joe (@aecnu)

    I knew that they would have to restart Apache, but didn’t realize it involved actually recompiling it. Regardless, if they are hosting elsewhere, it should just involve them contacting the host and asking for it to be done.

    James Dunn

    Athens, GA USA

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.