Cannot Activate Plugin(s) 500 Server Error

Help! I've successfully installed the WPMU DEV Dashboard on several sites - BUT this site just gives '500 server error' upon attempting to activate the plugin. I've done all the usual basics like ensure memory is right, PHP.ini is right, tried removing plugins, etc...
but still getting exact same error. Now, NONE of the installed plugins will activate (or better to say re-activate after disabling them). This is bad I need help... NOTE: This seems to have happened after the update to 4.5.3 but I'm not exactly sure :slight_frown:

  • Adam Czajczyk

    Hello Steven,

    I hope you're well today and thank you for your question!

    The "500 Internal Server Error" error is unfortunately one of the most undefined/unexplained errors of that kind but in case of WordPress it is usually caused by insufficient memory. I now that you already tried to increase memory but I'm not sure whether you did it for WordPress or for PHP only.

    That said, please start with adding following line to the "wp-config.php" file of your site:

    define('WP_MEMORY_LIMIT','256M');

    This line should be placed above the "/*That's all, stop editing..." line. Give it plugins' activations another try then and see if it helped.

    In case it didn't solve the issue please disable all the plugins at once by renaming "/plugins" folder on your server ('/wp-content/plugins") to something else, e.g. "/plugins.off" and logging in to site's dashboard. After plugins are disabled:

    - switch site to default Twenty Fifteen or Twenty Sixteen theme
    - rename "plugins.off" folder back to "plugins"
    - try enabling plugins one by one and see where it gets you.

    Let me know about the result please.

    Best regards,
    Adam

  • Steven

    Okay... All the wpconfig, memory & php.ini are all in place - as was from the clean install. So no changes there were required, but double checked everything to be sure. It was a plugin causing the problem. I was able to resolve the issue by removing a specific plugin and 're-updating' wordpress to the latest version. I also needed to double check and and re-load from backup the .htaccess.

    All is function as expected now.... whew! Not a big deal.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.