Cannot change e-Newsletter theme

I cannot change the theme on my e-Newsletter newsletters, it says – ‘The theme directory ‘{theme-name}’ doesn’t exist. Moreover, changes in the newsletters don’t save as well, it says it is saved, but once you reload the page, the changes are gone.

  • Predrag Dubajic
    • Support

    Hi amir levy,##1

    Hope you’re doing well.

    I tried checking your site but the support access doesn’t work anymore and the password provided in chat seems to be changed so I can’t check your site.

    Also, when I check your site from your WPMU DEV account it says that e-Newsletter is no longer installed there.

    Do you still need assistance with this and if you do could you please provide us with new login details to your site?

    You can send us your details using our contact form https://premium.wpmudev.org/contact/#i-have-a-different-question and the template below:

    Subject: “Attn: Predrag Dubajic

    – Site login URL

    – WordPress admin username

    – WordPress admin password

    – Link back to this thread for reference

    – Any other relevant urls/info

    Please respond in this ticket when details are sent.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Amir,

    Please don’t leave your login details here as these forums are public, we have removed your login from the comment but please change your password as soon as possible.

    I did check your site and I saw that you have Snapshot plugin there so I used it to backup your plugins and database and restore them to my local installation for additional testing.

    I was actually able to replicate the issue, however it doesn’t seem to be related to plugins and themes and it’s actually one of your settings causing it but I was unable to determine which one.

    I have forwarded all the information I gathered to our dev guys so they can investigate it further and check what from your site is causing this issue.

    Please note that developer response might be slower than usual staff response, so we appreciate your patience on this.

    Best regards,

    Predrag

  • Predrag Dubajic
    • Support

    Hi Amir,

    I’m afraid that I don’t have any good news yet, our developers are working on unusual issues like this one so it’s still being investigated.

    It seems to be related to something in your _users and _usermeta database but we’re still not sure why it’s causing it.

    Best regards,

    Predrag

  • Panos
    • SLS

    Hi there amir levy ,

    This is strange issue, I could only replicate with the tables I restored. Not sure what is causing it, but it seems to be falling in an endless loop when it filters the stylesheet hook.

    I have made a modification which should be removing this filter after first call in file:

    e-newsletter/email-newsletter-files/builder/class.builder.php

    I have attached file here so you can replace and let us know if this works for you too!

    I would recommend, before replacing the file, rename the original one to class.builder.php.txt so you can keep it as a backup.

    Thanks!

  • amir levy
    • Design Lord, Child of Thor

    Thanks,

    I replaced the file and now I can build a newsletter and save it while working on it. Unfortunately it is not showing the main content area in the preview.

    Furthermore, after closing the newsletter and trying to edit it again I the newsletter preview is empty (the editor fields are showing the content).

    It seems that now the problem is in the rendering of the preview window.

    Thanks Again

    Amir

  • Panos
    • SLS

    Really sorry for taking so long to reply here Amir.

    This seems to be related to some WP customizer settings but I was unable to find where those settings are stored.

    In a test site I imported the snapshot where I could replicate. What helped was to force show the #publish-settings button. This would allow to publish the newsletter. So after that it should be possible to save newsletters instead of drafts.

    You can force show that button by adding the following snippet on a mu-plugin:

    add_action( 'customize_controls_print_footer_scripts', function(){

    if ( is_customize_preview() && isset( $_GET['newsletter_id'] ) ) {

    ?>
    <style type="text/css">
    #publish-settings, .publish-settings {
    display: block !important;
    }
    </style>
    <?php
    }

    }, 9999 );

    After adding the above code you should better use a browser in incognito mode as it caches javascript and css. Now when you visit the Newsletter edit screen, you should be able to see a new button next to the "Save draft" button:

    Set the Action to Publish and save. I think it should have been set to "Schedule" somehow.

    After you save it should be ok to remove the script as the Schedule should have been removed.

    Please let me know if the steps to follow were not very clear. Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.