Cannot change spotlight image

Hello,
I'm trying to change the spotlight image. There are two images uploaded into the post, the first one that was uploaded was automatically grabbed as the spotlight image. After publishing, we decided we wanted to use the second uploaded image.
I set that one as featured in an attempt, but that didn't change the spotlight image.
I tried changing the order of the images by dragging and dropping the second inserted image ahead of the first in the media upload gallery, so that the sort order reads "1" as the image we want to be the spotlight thumbnail, and "2" as the first uploaded image that we do not want as the thumbnail. This didn't work either.

We're not using a caching plugin, and i've tried multiple combinations of saving changes, updating, and setting as featured to no avail.

On another post, we're having the same issue with the exception that we're trying to change the slideshow image, instead of the spotlight image.

Finally, can the slightshow or spotlight images be set exclusively (ie, different images selected for the spotlight than on the slideshow on single post that is tagged as being both a spotlight and a slideshow feature)?

Thanks

  • DavidM
    • DEV MAN’s Mascot

    Hi dbroome and welcome to WPMU DEV!

    The spotlight merely pulls the image from your post's featured image so changing that should change the spotlight image. From what you said it seems you tried changing that but could you try again, being sure to remove the existing featured image, changing it then saving the post?

    The same should hold true for the slideshow as well, that it relies on the featured image. Could you try this with your slideshow as well?

    Regarding your final inquiry, there's not an option for providing a different image dependent on whether the post is displayed in the spotlight or slideshow but you might be able to achieve that with some custom work. You can try posting the request to the job boards if you'd like to get that developed.

    Cheers,
    David

  • dbroome
    • WPMU DEV Initiate

    The featured image is what I expected to relay the change, and had experimented with it exhaustively prior to now, but it still does not seem to be working in this case.

    I just tried this:
    - removing the featured image. re-publishing.
    ---this results in no change.
    - Going back in and setting the featured image as the image i want to be
    - I'm doing this using the "add an image" icon, scrolling to the tab labelled Gallery (2), clicking "Show" on the row containing the image i want featured, then selecting "Use as featured image". I Save all Changes, exit the media popup, and Update the post.
    ---no change

    Having the same problem with the other slideshow post using the same general method i've described above... Suggestions? Are there hidden caching options in wordpress i'm not aware of? We had the total cache plugin running a few hours ago, but uninstalled it to remove that as the possible source of the problem. We've tested at least a dozen times since its removal...

  • DavidM
    • DEV MAN’s Mascot

    Caching could possibly cause the images not to update, but it should be easy to test that by viewing the post after the featured image is changed. If the image doesn't change after the update, it's likely having to do with caching.

    To help us see what's occurring though, is there any way we could get a link to the site?

    Thanks,
    David

  • dbroome
    • WPMU DEV Initiate

    Yes, we have tried this multiple times also, but it still sticks with the first image.

    I tried changing the order of the images by dragging and dropping the second inserted image ahead of the first in the media upload gallery, so that the sort order reads "1" as the image we want to be the spotlight thumbnail, and "2" as the first uploaded image that we do not want as the thumbnail. This didn't work either.

  • dbroome
    • WPMU DEV Initiate

    Hello again,

    I have tried this a few ways and it seems that the only way to manipulate which image is used in the spotlight image is the last image that was added to a post.

    Reording in the gallery for a post had no effect if I wanted to make one of the other images (and not the last to be entered one) the spotlight image.

    Can you concur with this finding?

    For example on http://blog-dev.finearts.uvic.ca/ curently the first spotlight item is the posting.

    http://blog-dev.finearts.uvic.ca/blog/2011/08/09/uvic-grad-maegen-mehler-wins-bmo%E2%80%99s-1st-art-bc-prize/

    The image of nmap from Diehard 4 is not the first image in the Galleries order. It is the last image added. It was added via uploading the the local computer and selecting to make it the featured image.

    Thanks in advance.

    Dave,

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!

    Otherwise, happy days, glad you got it sorted :slight_smile:

    Cheers,
    Phil

  • Tammie
    • WordPress Wizard

    So.. lets just back track a little get on same page.

    It was working.. then it wasn't then it doesn't for you Phil. Lets see where we are changing what so all on same page.

    Forgive the catch up just want to be sure.

    Where in fact are you changing the order - under image attachment order? Are we all working without plugins or maybe some have them? Also are we on the same version as this has happened over a span of time.

    I will work on a solution just want to make sure we're on same page with this and I can use the right testing set up.

  • dbroome
    • WPMU DEV Initiate

    Hello,

    Not sure if you are waiting for me. Sorry.

    Yes I am trying to set the order under Add an Image --> Gallery -> Drag to change the order and the image in the theme's slideshow (on the front page) only uses the most recently input image and not the highest ordered one. Is this the intended behaviour?

    There are a minimum of other plugins and it is still happening {BuddyPress, Akismet, Conditional CAPTCHA for Wordpress,WPMU DEV Update Notifications, Limit Blogs per User, Login Lockdown, Wiki Embed, Hotfix}. I have updated to the current version.

    Dave,

  • Tammie
    • WordPress Wizard

    Assuming you have the latest version of the theme can you upload the attached file to functions/ please. This works for me using no plugins so at least we can limit it down to being plugin related if this doesn't resolve it for you. I kind of think it will.

  • Tammie
    • WordPress Wizard

    I was and that fix worked for it. Are you sure you have no cache plugins and can you tell me exactly where the file was put please.

    Also please confirm you are on the same version as the latest version for BuddyPress, WordPress, and the theme (depending on what combination you are using).

  • dbroome
    • WPMU DEV Initiate

    Morning.... the file is in "/wp-content/themes/bp-scholar/includes" it replaced the original one.

    There are no caching plugins... Just want to confirm. On [1.] I am expecting that the upper image in the screenshot is displayed in the spotlight. That is the way it is supposed to work eh?

    1. http://blog-dev.finearts.uvic.ca/

    I did resave the post to confirm.

    http://blog-dev.finearts.uvic.ca/blog/2011/06/16/freshmans-win/

    Yes I am all up to date.

  • Tammie
    • WordPress Wizard

    Can you please try the attached patch. If this works I'm going to ditch using the attached images and go over to what we wanted to do which was use featured images. This will get it working for spotlight then in a week or so a patch will come out upgrading the other theme options and sections.

    You will now add an image under the bottom right in a post where it says 'featured image'.

    Just upload the patch files to their folders they list but DO NOT overwrite folders just move to the same structure.

  • dbroome
    • WPMU DEV Initiate

    Just checking.

    home.php -> /wp-content/themes/bp-scholar
    function-images.php -> /wp-content/themes/bp-scholar/includes

    I did this - set the featured image and no change. Hum.
    I changed the items that are listed in the category slideshow and the specific items show on the front page did change but not the image for the post I set the 'other' image as the feature.

    Dave,

  • dbroome
    • WPMU DEV Initiate

    Yes - the 'featured image' is showing there but not in the slider. The slide is updating to show the correct entries in the category ... I set another image as the featured image from the media library to another post and it too is not working.

    Dave,

  • Mason
    • DEV MAN’s Sidekick

    Hiya Dave,

    Well that is progress and (I think) what we were hoping to find. I believe the patch was meant to solely address the spotlight issue. Now that we've sorted that we can possibly modify the slider as well, but I'll let Tammie confirm that one as it does mean re-coding portions of the theme.

    Thanks for your feedback!

  • DavidM
    • DEV MAN’s Mascot

    Hi Dave,

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!

    Otherwise, glad you got it sorted :slight_smile:

    Cheers,
    David

  • dbroome
    • WPMU DEV Initiate

    Hello - I think this is still open as Tammie is looking for a way to define two images as the target of either the spotlight or the slideshow. Could the featured image be the spotlight and the order be the slideshow or is there another way to list an image as needed for the slideshow - perhaps similar to a way "Header images" are done in the Twenty Eleven theme?

  • Tammie
    • WordPress Wizard

    We will review this at some point but as said it's not that easy to implement and it works on a lot of sites just not yours in this case or the one testing. Whilst this we understand must be an issue for you we want to ensure the slideshow is done right if it is changes.

    I for instance can't recreate the slideshow as an issue where I did recreate the other areas and actually provide a fix already for that. As a result this is going to be an enhancement not a bug fix. I do not consider it a matter that won't happen it's more it has to be done right.

    So, for now we're closing this and we will review as it's on the enhancement list as it indeed is an enhancement for the slideshow.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.