Cannot create account with Membership Pro 2

Having an issue where users cannot sign up. Simply follow the “Account” tab in the menu, and attempt to sign up for a subscription. Annual was what was tested. When you’re done submitting your account information (name, username, etc), the form will simply refresh the same page and form, blank. It doesn’t go or do anything.

Any ideas? Support access has already been granted, if that helps. Site is live at http://preservationartisans.org

  • Sajid
    • DEV MAN’s Sidekick

    Hi Charlie Pryor,

    Hope you are doing good today :slight_smile:

    To make sure its not a bug in the plugin I tested it on my test site and it worked fine for me.

    It appears to be a plugin or theme conflict. Please run a plugin/theme conflict test as a basic troubleshooting protocol to exclude this reason.

    Disable all plugins at once, switch to default WordPress theme (e.g TwentySixtee) and then try to signup again. If it works this time then activate each plugin and theme one by one and keep checking the signup page to find out what plugin or theme is causing the issue.

    I avoided to make a test on your live website without your permission and without having FTP access.

    Take care and have a nice day :slight_smile:

    Best Regards,

    Sajid

  • Charlie Pryor
    • The Incredible Code Injector

    Plugin conflict confirmed. Needed an update to Contact Form 7. Quite odd that this would mess up a signup form for a WPMU Dev Plugin, but then again, I don’t know code, so maybe it’s not all that strange.

    Anyways, issues seems to be resolved, at least for now. Thank you for the reply.

  • Charlie Pryor
    • The Incredible Code Injector

    I’m afraid I have to reopen this, as it’s still affecting users attempting to sign up. Plugin conflict is unlikely, due to the limited amount of plugins active anyways. The problem exists exclusively with Chrome, from what our testing can see. Firefox appears

  • Charlie Pryor
    • The Incredible Code Injector

    I’m afraid I have to reopen this, as it’s still affecting users attempting to sign up. Plugin conflict is unlikely, due to the limited amount of plugins active anyways. The problem exists exclusively with Chrome, from what our testing can see. Firefox appears to work out just fine. Any ideas? It’s a live site… you can see what plugins are active. Feel free to deactivate and test as you see fit. Fine with me.

  • Nastia
    • Support Rock Star

    Hello Charlie Pryor

    I hope you are doing well today!

    I can reproduce this issue with Chrome and with Firefox, the Register page does refresh itself, however the users are registered.

    Once I deactivated all other plugins and switched to a deafult WordPress theme, the registration went well. The new user was redirected “Join Membership” page.

    This issue caused for sure from a conflict with another plugin. As it seems there is a conflict between the child theme and W3 Total Cache plugin.

    Would you pelase try another cache plugin? You can try the WP Super Cache :

    https://wordpress.org/plugins/wp-super-cache/

    Let us know how it goes!

    Kind Regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.