Cannot edit menus in multisite subsites

Hello,
When I create a new sub-site eg schooladvice.net/rsa I am unable to create menus. The menu appears on the new site (inherited from the cloning of the sub-site) however when I go to Appearance Menu it's not there and ask me to create a new menu. When I do create a new menu it does not save. I use DIVI theme. My older subsites are good I can change menus but any new sub/multisite I create I cannot. Very frustrating.
Can you help me with this?
Thanks,
Michael

  • Adam Czajczyk

    Hello Michael Hayes

    I hope you're well today and thank you for your question!

    You mentioned that there is a menu "inherited from cloning of the subsite". Does this mean that these new sites are not created from front-end or via back-end "Network Admin -> Sites -> Add new" but instead are clones of existing sites?

    If yes:

    - how do you clone them, is it with our Cloner plugin or some other tool?
    - have you tried to manually create new site ("Network Admin -> Sites -> Add New") and if so can you add/edit menus there? If you didn't try it, could you give it a go please?

    Let me know, please.

    I would also like to take a closer look at your setup so would you mind enabling support access for me? To do this, go to the "Network Admin -> WPMU DEV -> Support" page and click on "Grant Support Access" button there, then let me know here.

    Best regards,
    Adam

  • Michael Hayes

    Thank you for your timely reply.
    I have the same problem with menus when I use the WPMUDEV Cloner Plugin or when I add a site manually. Today I used the cloner plugin on a subsite where the menu IS editable thinking this function would carry over to the cloned site. But not the case - the menu remains invisible.

    Sites that were made months ago do not have this problem, it's only recently - the last few months that I've noticed the issue.

    I will go to my site and provide you with access as requested.

    Thanks
    Michael

  • Predrag Dubajic

    Hi Michael,

    I tried testing a couple of things on your site but indeed manually created sites are not creating menus as well, and there's nothing in there that would point us to the cause :slight_frown:

    Would it be possible to set up a staging site and disable all your network enabled plugins to see if any of those are causing the issue?

    If that doesn't give any results can you enable debug log in your wp-config.php file (located in root WP folder) by replacing define('WP_DEBUG', false); with this code:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set( 'log_errors', 1 );
    @ini_set( 'display_errors', 0 );

    Try to create new menu and this should create debug.log file in your wp-content folder that could tell us what is going on.
    Can you please save it as .txt file and attach it here so we can check it out.

    Best regards,
    Predrag

  • Michael Hayes

    Good Day!

    Thanks for the great advice. I created a staging site and went through the plugins 1 by 1 and found the issue.

    The Plugin 'Category Order and Taxonomy Terms Order' causes the menus to grey out. Disabling that does the trick. This means I can at least edit the menus and turn the plugin back on after. I'm going to get in touch with the plugin people and let them know about this conflict.

    Thanks again - We love WPMUDEV here at SchoolAdvice

    Michael Hayes

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.