Cannot enable browser caching in Hummingbird

I have my own server and have confirmed that mod_expires is correctly enabled, yet even if the browser caching rules are manually added to .htaccess, Hummingbird's module claims mod_expires is not enabled.

  • Adam Czajczyk

    Hello Peter

    I hope you're well today!

    The support access seems to be inactive now (on my end) so I couldn't take a look inside. But I checked the site from outside and it apart from some external resources (so it's not related to your server) and PNG images it doesn't actually seem to be detected as browser cache enabled.

    Some of the resources return Etag which might be breaking the browser caching as well.

    However, I think the issue here might actually still be related to Apache configuration. Hummingbird adds some rules to .htaccess that are supposed to set the browser-caching "configuration". But it might not be applied sometimes. For example:

    When the Expires header is already part of the response generated by the server, for example when generated by a CGI script or proxied from an origin server, this module does not change or add an Expires or Cache-Control header.

    [https://httpd.apache.org/docs/current/mod/mod_expires.html]

    That being said, I'd suggest checking following things for the start:

    1. Disable ETags by replacing this line in .htaccess

    <IfModule mod_headers.c>

    with this

    <IfModule mod_headers.c>
    Header unset ETag

    and adding this

    FileETag None

    right above the

    </ifModule>

    in Humingbird's caching code.

    2. Do you have any server-side caching solution, especially Varnish installed? If so, try disabling it temporarily as it usually sends caching headers "on its own" and that would affect settings enforced by Hummingbird.

    3. There might be something else sending these headers. Just to test it, it would be good to temporarily disable all the plugins and switch to Twenty Seventeen theme, keeping browser caching rules in .htaccess and then test the site against browser caching, if those 2 steps above doesn't change anything.

    If none of that works, would you please make sure that the support access is enabled again so I could take a closer look at the site?

    Best regards,
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.