Cannot get domain mapping to work

I would like to request support access please. I have tried everything to get domain mapping to work and having no luck.

WP multisite 4.)
Godaddy Ultimate shared hosting
Dedicated IP address
Multisite set up as subdomain and working fine.
SSL wildcard set up and working on multisite.
WP HTTPS / SSL setup and worked ok
Domain name A record pointing at WP dedicated IP address
Mapped domain name to subdomain which is valid OK
Website showing a redirect loop in browser.

I have granted support access to you already.

Would really appreciate your help checking my settings and helping to get the domain mapping working as I have another LIVE client site that I need to launch urgently.

Many thanks,

Sean.

  • Michael Bissett
    • Recruit

    Hey @plinthid, hope you're doing well today! :slight_smile:

    When I try to view your site from a logged in perspective, the address keeps switching between http & https, even when I keep Domain Mapping from forcing either http or https on a mapped domain.

    Could you post your htaccess rules here please, so that we can have a closer look at them? Also, could you mention who your host is, and if they have Varnish caching enabled on your hosting?

    Please advise,
    Michael

  • plinthid
    • WPMU DEV Initiate

    Hi Michael, thank you for your reply and help.

    Godaddy is the host.

    No idea if they have Varnish caching enabled. Would you like me to call them and find out?

    Should Varnish caching be enabled or not?

    For security reasons I have changed my real multisite domain name to mymultisite.com

    Would you like me to set you up as a super admin on my WP multisite?

    The subdomain that I am using for testing is adaptivexperience.mymultisite.com

    The domain that I want to map for testing is adaptivexperience.co

    Does WP HTTPS / SSL cause any problem with your plugins?

    I am trying to use only WPMU plugins for everything if possible but as yet have not found a better solution to WP HTTPS / SSL
    http://www.mvied.com/projects/wordpress-https/

    # BEGIN HTTPS Redirection Plugin
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    # END HTTPS Redirection Plugin

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On

    RewriteCond %{SERVER_PORT} !^443$
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>

    # END WordPress

    RewriteCond %{HTTP_REFERER} !^https://*.mymultisite.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://*.mymultisite.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://mymultisite.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://mymultisite.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.*.mymultisite.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.*.mymultisite.com$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.mymultisite.com/.*$ [NC]
    RewriteCond %{HTTP_REFERER} !^https://www.mymultisite.com$ [NC]
    RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

  • plinthid
    • WPMU DEV Initiate

    Hello,

    please advise what work has been dome on my site.

    NOW I have no access to my multisite PLUS none of my client sites are working.

    I need this fixed immediately or I will have clients calling me soon very angry.

    I had no problems accessing client sites or subdomains before Michael started looking at the site.

    This is very urgent.

    Thanks, Sean.

  • Vinod Dalvi
    • WP Unicorn

    Hi Sean,

    Thank you for your reply.

    I can access your site plinthcms.com admin area using support staff access.

    Could you please tell me which sites you are facing problem accessing it?

    You can just deactivate all of your plugins by renaming plugins flder using FTP/File manager as described on the following page and reactivate it one by one to know which plugin is causing this issue if any.

    https://premium.wpmudev.org/blog/daily-tip-how-to-quickly-disable-all-wordpress-plugins/

    Regards,
    Vinod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi Sean,

    If you can access admin area of your site then you can remove domain mapping plugin by deactivating and deleting it.

    If you can't access admin area then you can remove it by deleting the domain-mapping folder from your plugins folder using FTP/File Manager.

    Regards,
    Vinod Dalvi

  • Timothy
    • Chief Pigeon

    Hey there,

    If you're using HTTPS then each site/domain name will need their own cert, this means they need their own IP, WordPress isn't currently set to handle that.

    A wildcard SSL cert will cover all sub domains, but for the customers own domains you'd need a different type of cert, something like:

    https://www.globalsign.co.uk/ssl/multi-domain-ssl/
    https://www.namecheap.com/security/ssl-certificates/multi-domain.aspx

    That can be costly, and would require some research.

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.