Cannot get rid of the "index.php"

My site URL is https://p*****.ac.uk/wordpress, but WordPress appends index.php to my site URL in my permalinks settings. Because of that CoursePress links don’t work.

I don’t know how to get rid of that index.php

  • Ash
    • WordPress Hacker

    Hello SOPHIE

    Though your htaccess has a problem, fixing it didn’t resolve the original issue.

    After looking at your setup it seems, index.php is forcing from the server level. Because, when I remove index.php and save permalink and update htaccess and it still didn’t work.

    So, I can think of two possible issues:

    1. Check your vhost file if you manage the server, or ask your host in case of shared server. You must need the following in the vhost file to make the htaccess working:

    AllowOverride All

    2. Check in the vhost settings, if there is any rule setting RewriteBase to index.php (that was in your htaccess file)

    Let us know how it goes. Have a nice day!

    Cheers,

    Ash

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.