CANNOT INSTALL APPOINTMENS+ I GET Server error status: Internal Server Error [500]

can someone please help me how can i install this plug in and does it work/?