Cannot install Defender

We are trying to install Defender and cannot. Error suggests that it might be permissions on wp-content folder, however, even if we put them to 777 the install fails. We have returned the permissions to what they should be, but still cannot install?

  • Rupok

    Hi MSAMike,

    So sorry to hear the inconvenience you are having. Can you please confirm your "wp-content" directory has recursive 755 or 750 permission? Recursive means all directories inside the "wp-content" directory should have the same permission.

    If not, can you please try giving 755 or 750 recursive permission for all your WordPress directories and 644 or 640 recursive permission for all your WordPress files? I believe, that will help.

    If that doesn't, can you please try downloading the plugin from this page: https://premium.wpmudev.org/project/wp-defender/
    And then manually installing from the "Dashboard > Plugins > Add New" section? Please let us know how it goes.

    If you can install this plugin manually but can't install through the WPMU DEV Dashboard plugin, then can you please check if you face this issue only while installing Defender through DEV Dashboard or you face this for all plugins through DEV Dashboard?

    Please let us know all these details. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.