Cannot install Membership Premium and a question about WooCommerce

Question 1:

During install, I get the following error:

"An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums."

Should I maybe try upgrading WP to 3.5? However, I've had quite a few themes break on me recently during upgrade so I'm slightly reluctant to do this until a theme update is available. (The site is currently running Akita by Theme Boulevard).

Question 2:

The site is also running WooCommerce and one of the 'pages' I wan't to make protected (members-only) content is the main shop page. Is this possible? I installed Lite to try this out and the shop page didn't appear in the list of pages to protect...

Many thanks,

Sian

  • phillcoxon
    • The Crimson Coder

    Question 1: Quite a strange error to get. That was when you tried to install the full Membership plugin? Did you install it via the WPMUdev dashboard or uploaded it manually?

    Did the plugin install at all, or simply respond with that message?

    Staying up to date with WordPress versions is always a good idea. However, you should always back up first especially when doing a major version update as that's when plugins tend to break most with new versions of WP. You can use Snapshot or a plugin like BackupBuddy which I use.

    That way if the upgrade goes wrong you can restore the site very quickly.

    Question 2:

    So you set up a Free / Visitors level and added pages you wanted to hide with negative rules including the shop page?

    Doesn't the shop page appear in the list of pages you can set a negative rule for?

    It should work fine for the WooCommerce shop page. With that said I've only used the full Membership not Membership Lite so I'm not sure if there's a difference.

  • sian_jones
    • Flash Drive

    Hi there,

    Not sure if you received my email response a few hours ago... this is a re-cap anyway:

    "I tried installing the full version through WPMUdev. It didn't install at all - just gave me the 'unexpected error' message above.

    I don't know if this is of any significance but when I turned debug on I get the following PHP error:

    Notice: add_contextual_help is deprecated since version 3.3! Use get_current_screen()->add_help_tab() instead. in /home/sese1245/public_html/wp-includes/functions.php on line2638

    Regarding my second question, yes i wanted to add what is basically free membership with 2 pages hidden to non-members. For members i made all the pages available and for everyone else (i.e. non-registered users) I hid the pages I could (no shop page visible) using the negative rules.

    The very odd thing is that other WooCommerce templates are visible in the list - including checkout, view order etc."

    Okay - so I've now finally backed up the entire site (it's huge at nearly 1.2GB) with Backupbuddy and updated to WP 3.5.

    I've also deactivated and deleted Membership Lite but on installing Membership full plugin from WPMUdev i now just get an error (visible on the install button itself - please see attached screenshot).

    Help! :slight_smile:

    Sian

  • phillcoxon
    • The Crimson Coder

    Wow - 1.2Gb sounds like an immense amount of data. What are you backing up there - lots of images, or previous backups? Unless your shop has hundreds of product images I wouldn't have expected the backup to be so large.

    When you get the error message on install, did it give you an actual error message when you click on the error button?

  • sian_jones
    • Flash Drive

    Yeah... I know! - it's rather ridiculous but there are about 140 products so I guess they're the culprit there. (Also,I didn't upload these myself so not sure if they have huge image files).

    There could be a ready-stored backup or two in there too, will check before next backup.

    I'm afraid I don't get any error message when i try to install just a 'downloading' animation for a while and then "error"...

    Sian

  • phillcoxon
    • The Crimson Coder

    Glad to be able to help. :slight_smile:

    Checked out the site - nice! Didn't see where woocommerce was located though.

    When checking out the size of backups have a look through your folders and make sure you're not accidentally backing up previous backup zip files that may have been left lying around somewhere. I've seen that happen a bit.

    I'll mark this ticket as resolved and you can re-open it if you have any other questions.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.