Cannot load install-required-plugins

Anyone know why I get this error when I click on a 'begin activating plugin' link at the top of my dashboard (for a recommended plugin). Updates/activations/installs work fine when I go to the plugins page direct. I've tried reinstalling the core files but no joy. It doesn't actually stop me doing anything but just feels like I shouldn't be getting the error.

Thanks!