Cannot log into wp-admin I think the website is stuck in a redirect loop

Hi guys, I'm tearing my hair out on this one. I have followed so many links and tutorials but have had no luck.

I have a website http://h-und-p-consulting.de/ which works from the front end but when I try and log into the website via [removed] it does nothing eventhough I have the correct password. Try for yourself

[removed for member's security]

if you type in an incorrect password it says that you have the incorrect pw and I've also reset it via phpMyAdmin.

I have also tried the following things all without luck
> Renamed the plugin folder
> changed the .htaccess file
> repaired the db via phpMyAdmin
> changed themes
> changed servers

I think something is wrong with the database, because prior to this happening I couldn't even publish a post it kept on saying "pending review" instead of publish. I'm sure there's a conflict of permissions somewhere?

You can log into the Plesk panel for the website by going to:

[removed for members security]

(it's in German) but I'll tell you where to go :slight_smile:
Once logged in go to > Domains in the left hand side > then select http://www.h-und-p-consulting.de and click on the very right hand side link (In Control Panell offnen)
Once the new page has loaded you will need to scroll down to "www.h-und-p-consulting.de" click on "File manager" to access files or "Datenbanken" (hundpcon_wp1) for databases.

Your help would be greatly appreciated.

  • Jude

    Hi there Flo,

    I have marked this as Internal, which means only you or one of our staff can see this. Please don't post username or passwords on this forum, its public and anyone can take it and hack your site.

    I tried looking in, but everything is in german and Plesk does not support Google Translate so well.

    I ran some tests on the Login page. This is what happens, the form submits and when the login is successful the server sends in a blank response. This means that some plugin / custom code / theme function hooks on to the login hook and modifies it or redirects. Unfortunately the code has errors and does not excecute correctly and this causes it to fail and WordPress is forced to send back a blank response via AJAX.

    Here is how you can fix it.

    1) Delete everything in the plugins page and copy it somewhere else and try. If this works then copy each plugin folder one by one back and activate and test each one

    2) If that does not work then do the same with the themes folder, keep only the default themes and delete any themes you installed.

    3) If that does not work check your WP-CONFIG file and PHP error logs for any issues relating to wp-login.php

    4) If that does not work do a MySQL dump of your DB and send it to me

    Cheers
    Jude

  • Jude

    Hi there @Flo

    I completely missed this thread, I though it was fixed as I did not hear back in a while Until today when a colleague pinged about this.

    Have you changed anything ? The site I'm seeing and the dump I have don't match ? Looks like you reset the whole thing, but let me know.

    Also if you need further assistance please send in

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    - phpMyAdmin details ( To check database )
    - MySQL details ( IF you dont have phpmyadmin)

    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Note: I may change language for a bit when I'm on the site/

    Cheers

    Jude

  • Mary

    Vinod,

    I had the same problem a few days ago when I could not log in to my admin account. This occurred after I activated Ultimate Branding and started to set it up. The next time I tried to log in, I was locked out. I was also not able to reset the password on the front end because there was some error in the system that would not send me an email with a link to reset.

    Luckily I had another Admin account. I went in, deactivated Ultimate Branding, logged out of that admin acct. and was able to log in to my regular Admin acct.

    I'm not necessarily blaming this on Ultimate Branding, but I think something it allowed me to do while setting it up may have caused this.

    I am only answering this because it seems at least a couple others have recently had the same or similar problem.

    Thanks for your fantastic support.

    Mary :o)

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.