cannot login to access content

Hi,

I have set up "pay per view".

I am testing my content. With the "one item" purchase, I can get to my paypal account.

With all other access levels, I can't get past the login to make payment. Help?

How do I get the "Login with Facebook", "Login wiht Twitter", "Login with Google" and "Login with WordPress" to work?

"Login with Facebook" just doesn't respond - no new page, no error, nothing.

"Login with Twitter" just gives me a blank pop up.

"Login with Google" gives me "400. That’s an error.

OpenID auth request contains an unregistered domain: http://www.showmehow.today".

I tried "Login with WordPress" through "Register" and it says "Registration has been disabled.".

Help please!

Thanks,
Elina

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    Thanks for posting on the forums.

    To make sure have you configured the Facebook and Twitter APIs in the API Settings section from the following path?

    Admin area -> Pay Per View -> API Settings

    Could you please share me the page link where it is displaying?

    Kind Regards,
    VInod Dalvi

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    Try unchecking "My website already uses Facebook" option.

    You can just grant me temporary admin access to your site by clicking "Grant Access" button in the WPMU DEV Dashboard Settings from the following path and reply on this thread after granting it?

    Admin -> WPMU DEV -> Support -> Support Access Tab

    Regards,
    Vinod Dalvi

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod,

    Unchecking "My website already uses Facebook" worked. I've had to do some additional configuration for the FB App. Now that it is sorted, it actually asked me for my details. So I'm good for FB.

    How about the others?

    Also, I have granted you temporary admin access.

    Regards,
    E

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    I tried "Login with WordPress" through "Register" and it says "Registration has been disabled."

    This is because you have disabled the new registration.

    Please allow new registrations from the following path.

    Network Admin Area -> Settings -> Network Settings -> Registration Settings

    I am troubleshooting the Google and twitter issue.

    Cheers,
    Vinod Dalvi

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod,

    Done as you have instructed and tested the login. Works perfectly for the WordPress part now (ie I can get to the payment page).

    Haven't gone beyond the payment page to test the rest of the functionality.

    Awaiting the Google and Twitter components.

    Many thanks!

    Regards,
    E

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod,

    This was the only bit I could find on the Twitter error: https://dev.twitter.com/discussions/17911

    But not 100% sure where I'd find the "redirect_to request.env['HTTP_REFERER']" for removal of the "request.env['HTTP_REFERER']".

    I've played around with a whole bunch of settings for Google and have even installed the Google+ plugin. Didn't help.

    I've kinda run out of ideas for now (and it's 2am where I am).

    So would appreciate it if you find something good to overcome my issues. But I think my brains are shutting down on me now. :slight_smile:

    Talk later,
    E

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    The Google log in is working for me on my test site but not on your site. I think this is because the Google has disabled OpenID 2 for new domains in May 2014.

    The reason why some hosts work and some don't is that although Google isn't adding new hosts, you can still use the ones that are already registered.

    I have notified the plugin developer to get his reply here regarding the issue.

    For the testing purpose i tried using Twitter Consumer Key and Consumer Secret of my twitter app on your site and it worked fine without any issue.

    Could you please check that you are using correct Twitter Consumer Key & Consumer Secret in the Pay Per View settings and also you have configured the twitter app correctly?

    Please share us the screenshot of twitter app settings if you can.

    You can also try creating another new twitter app and using its Consumer Key & Consumer Secret.

    Regards,
    Vinod Dalvi

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod and Jack,

    Apologies I was offline for a couple of days. Couldn't get any useful screenshots from Twitter. Will try again a bit later.

    Alternatively, I could try Vinod's suggestion in a few hours' time (new twitter App with credentials). But I'm fairly certain it's accurate, unless cut and paste added in additional text. Is there some way I can get more error details?

    Thanks for your help.

    E

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    Is there some way I can get more error details?

    The error we are getting is as following.

    Whoa there!
    There is no request token for this page. That's the special key we need from applications asking to use your Twitter account. Please go back to the site or application that sent you here and try again; it was probably just a mistake.

    There are various reasons of generating this error discussed on the below page.

    https://dev.twitter.com/discussions/7788

    Let's try to resolve it using solutions one by one.

    It's working fine using the my twitter app credentials therefore i think there is something wrong with the configuration of your twitter app but i don't know exactly what's the wrong.

    Cheers,
    Vinod Dalvi

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod,

    That's exactly the same error I received.

    Can I trouble you to show me what your twitter app page looked like (the one that worked?). I'm pretty new to all of this, so might be doing the wrong config on my end. :slight_frown:. If I know what should be done, maybe I'd be able to follow instead of randomly taking screen shots of what I think should be right?

    Thanks!

    E

  • Elina
    • Design Lord, Child of Thor

    Hi Vinod,

    I've attached the screen shots of my setup. The API key corresponds to the Consumer Key and the API secret corresponds to the Consumer Secret. Still no luck.

    Are there other things I need to set up on the Twitter account?

    When I test the oauth, I get the error "Invalid auth/bad request (got a 403, expected HTTP/1.1 20X or a redirect)". After I generate a token, it still gave this error.

    Help?

    Thanks,
    E

  • Vinod Dalvi
    • WP Unicorn

    Hi Elina,

    Thanks for sharing the screenshots.

    Initially it seems from the screenshots that the twitter app settings is correct.

    Try regenerating API keys and creating new twitter app, also check whether the solutions posted in the following pages helps you to resolve the issue or not.

    https://dev.twitter.com/issues/432
    http://stackoverflow.com/questions/8819692/error-invalid-auth-bad-request-got-a-401-expected-http-1-1-20x-or-a-redirect

    Regards,
    Vinod Dalvi

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.