Cannot Post to Facebook (Options missing)

I cannot post content to facebook because the option to do so is missing from the posts page.

I only see "post to facebook with a different title" no option to actually send the post.

Unlike the screenshot in the usage instructions
https://premium.wpmudev.org/wp-content/uploads/2012/03/25.png

  • Arun Basil Lal

    Hello ArticleCK

    You have auto-posting on for every posts automatically for all the posts. In the AutoPost to Facebook settings, there is an option "Allow autoposting new posts to Facebook". You probably have that checked. Un-check that and you will see the detailed box

    The detailed meta box shown here: https://premium.wpmudev.org/wp-content/uploads/2012/03/25.png is for post by post control when you have Auto-Posting disabled.

    When you have auto posting enabled there are one set of settings for every new posts and you can configure them in the "Auto Post to Facebook" section on the Ultimate Facebook settings.

    Note that posting to Facebook happens when the post is published and works for new posts

    Let me know if you have more questions. Cheers!

  • ArticleCK

    I think this was the problem, but now I cannot grant extended permissions.

    They were granted before I unchecked this box. In the initial set up, everything
    went well and I granted permissions for the app... or at least I thought I had.

    Now I am told that I need to with a warning that was not there before. But no
    matter how hard I try, I cannot do this. A popup loads and closes fast if I
    am already logged into facebook, or asks me to log in, then does the same
    if I am not.

    I have tried logging out of facebook and wordpress and deleting browser cookies.
    I have even tried, having a cup of tea and coming back to it.

    Nothing works.

    So I still cannot post anything, because it will not allow me to.