Cannot rename a page back to its original name

I may be overlooking something simple but I have a page on my site that was originally called “Sellers”. Sometime in the past I may have deleted this page and recreated it. The problem is that when I did it got renamed to sellers-2. I tried to rename it back to sellers but it only got bumped up to another name sellers-3, then sellers-3-2 etc.

For some reason the system won’t let me use sellers anymore. I am aware that if a page is in the trash that I need to delete it permanently then try again with the new name but I do not have any pages in my trash. Is there maybe something in the database that may be preventing this? If so where do I track this down?

I will really like to get the original name back.

This is wp 3.0.4

Dave

  • drdave
    • The Crimson Coder

    There are few names Sellers under post_title for wp_post in the database if this is what you refer to. I’d imagine they are just old post entries. Or where do I find this slug? I already checked all the slugs in admin pages.

  • DavidM
    • DEV MAN’s Mascot

    Hi there drdave,

    Just to check, are your permalinks set to simply %postname%?

    If so, maybe you could try changing the permalinks to something else temporarily, then changing the page slug, then changing the permalinks back to %postname%.

    Have you tried this, by any chance?

    It seems pretty clear that the problem is that you have a post titled “Sellers” in your database that’s keeping you from having that slug in your pages. So I’m just trying to figure out ways of working around that.

    Cheers,

    David

  • drmike
    • DEV MAN’s Mascot

    There are few names Sellers under post_title for wp_post in the database if this is what you refer to.

    Sounds like you may have post revisions/ drafts/ autosaves whatever they want to call them still turned on. That’s known for filling up your wp_post database.

    Try steps two and three in this thread:

    http://wordpress.org/support/topic/cant-delete-drafts-3

    Afterwards log out and log back in to see if that helps.

    -drmike

  • Philip John
    • DEV MAN’s Apprentice

    Hi Dave!

    Take a look at your Trash (Posts > Trash) and see if the old version of the page is in there.

    If it is, you’ll need to “Delete permanently” – until you do, WordPress still considers that slug to be taken!

    One of those “features” that ends up being annoying :wink:

    Phil

  • drdave
    • The Crimson Coder

    @philipjohn nothing in trash as mentioned.

    @drmike I have no drafts listed so not sure what I will be deleting.

    @davidm the permalink was changed, slug renamed and it did work. Got (sellers) back, but when I switched permalink back the slug reverted back to (sellers3).

    Sounds like you may be on to something here. I used /%category%/%postname%/

    Actually /%category%/%postname%/ been my permalink setting all along but I had to change it for some reason am thinking because of a plugin and for some reason w3 Total Cache comes to mind but I cannot remember the reason.

    Guess it’s time to go back checking for any previous problems if I am to revert back to my old permalink settings or just settle for a new slug.

    Just my nickels

  • Philip John
    • DEV MAN’s Apprentice

    Dave,

    You might want to try this post on wordpress.org as per drmike’s suggestion which says;

    To delete these pages you need to use a MySQL front end, go to the posts table, sort on post_status and all the auto-drafts will come to the top for ease of deletion.

    If you have phpMyAdmin that should be fairly straight-forward. Just select your database, browse to the wp_posts table and click on the heading for post_status to see auto drafts come to the top.

    Or, you could click on the SQL tab and run a query like;

    SELECT * FROM wp_1_posts WHERE post_name = ‘sellers’

    Let us know what happens with that…

    Phil

  • drdave
    • The Crimson Coder

    @phil @drmike

    Deleting those database entries were completely ignored. After renaming sellers from sellers3 to sellers and updating it now says sellers6.

    There are no new Draft entries in the database after doing this.

    Is there like a definite solution to this problem that someone may know about? Since it is only making the situation worst each time I change the page name.

    Dave

  • drdave
    • The Crimson Coder

    Phil I had a subsite by the same name “Sellers” and why all the strange behaviour. Once I renamed it I was able to get the name back for that page then everything was back to normal. I had forgotten all about the site not having used it.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.