Cannot run snapshot on this site

When I try to run snapshot on http://xmodular.net/selftraveltourpoint
it hangs when it tries to backup the last item (files).
This site has a lot of files, that's true, but it doesn't mean that must be no way to run snapshot. Which way to fix?
I've got you dashboard access so you can check there directly.

  • Adam Czajczyk

    Hello italydotcom,

    I hope you're well today and thank you for your question!

    I reviewed your site and also tried to setup a new snapshot for this site. However, I wasn't even able to get to the point you described in your post. I was getting another error (reported by Snapshot plugin) related to DB tables and this happened for both the snapshot that you created and that new one.

    That said, I forwarded the error to one of the Snapshot developers and asked him for help on this. Please keep an eye on this thread and I'll update it as soon as I get a response from him.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello italydotcom!

    Thanks for explanation. I visited the site again and run snapshot again. There was no errors anymore and it indeed got stuck at some point. It seems it's not able to process this image:

    http://xmodular.net/wp-content/uploads/2015/01/favicon-16x16.gif?a4341dfe52726369fc53c3849f08d657

    Even if it's called directly via browser (with and withough the "?...." part) it's casing server to return "500 Internal Server" error. That's weird issue, I admit but it explains why Snapshot gets stuck instead of simply skipping/ignoring the file.

    Therefore, I think we need to find out why that file is returning 500 Internal error. I reviewed the site in question and it seems there's currently now favicon set so this puzzles me a bit more. However, it's possible that it has been created (e.g. setup in Avada theme options) and then physically removed from the server? Or if it's a broken file?

    What I mean is that you may want to access your server via FTP and check /wp-content/uploads folder for this file first. It may be good to re-upload it or just remove it (since it doesn't seem to be used anyway) and then set a new favicon for site. Would you try this first? I'd like to see if this affects the issue at all.

    Best regards,
    Adam

  • italydotcom

    Hi, thanks for your quick and in depth analisys and answer.

    Problem is this:
    THIS FILE DOESN'T EXIST!

    In fact, there is not the whole directory http://xmodular.net/wp-content/uploads/2015
    so may be that many other files are missing.

    So, it seems to me that somewhere in some table there is a wrong reference to files that are not still there, and program hangs.

    Is there any fix in the meantime?

  • Predrag Dubajic

    Hi italydotcom,

    Mind if I chim in here :slight_smile:

    I had a look at your site and tried excluding /2015/01/ folder from the snapshot but it was still failing so it looks like there's something else here causing it.

    Can you check your uploads folder and check subfolder sizes, perhaps there's a large folder that server can't handle and that's why it fails?

    Looking forward to your response.

    Best regards,
    Predrag

  • Adam Czajczyk

    Hello italydotcom,

    Thanks for providing us with this information.

    It seems that the "size" may be indeed an issue here. An ID of the site in question is "34" and as the screenshot shows its "uploads" folder is over 4G size in files. That's huge but nothing that Snapshot wouldn't handle unless there's a file (or multiple files) that are very large and/or broken.

    The missing file shouldn't be the issue as Snapshot should skip it but a huge file may be an issue. However, knowing of the size of the file, I'm wondering whether we shouldn't give it much more time so it could try to complete the operation anyway.

    I'm thinking of this because of two reasons:

    - if it's a single huge file that's "blocking" it, it's most likely handled "in chunks" and since Snapshot does it triggering functions over AJAX it may take quite an amount of time to complete

    - if it's a matter of handling a large number of small files, again - some time may be needed (a good example is an FTP transfer: try transfering a single 1GB file and a 1000 1MB files, there'll be a significant time difference).

    That said, I understand that you already tried to wait for this to complete. What was the longest time you let it continue for?

    Could you try first enabling WP debugging (so we may have a log of what was going on) and then try again giving it, let's say, twice or even three times that time to complete?

    If it does complete, I'd say issue would be solved. If not, then I'd like to take a look at debug log.

    In order to enable debugging please add following lines to your "wp-config.php" file:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    These lines should be placed above the "/*That's all, stop editing..." line. To download and share a debug log with me please
    - access the site via FTP
    - download the "/wp-content/debug.log" file
    - rename the file to "debug.txt"
    - attach it to your post here.

    Best regards,
    Adam

  • Predrag Dubajic

    Hi italydotcom,

    Can you try excluding the /sites/34/ folder from the snapshot so we can check if that's indeed the cause of this?
    To exclude folder go to your snapshots, click to edit desired snapshot and on right site where you will see exclude field and then just paste this in there:
    /sites/34/

    If I/O limit is low compared to file size it could come to server timeout but let's see first if the 34 folder is what's causing this.

    Best regards,
    Predrag

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.