Cannot run the script provided by config tool

Hello!

I'm new to both multisite and multi-db.

I tried to run this on SQL tab in PHPMY Admin:

CREATE DATABASE aw1ms2_global DEFAULT CHARACTER SET utf8 COLLATE utf8_general_ci;

but I got this error:

#1044 - Access denied for user 'misiedum'@'localhost' to database 'aw1ms2_global'

What's wrong?

  • Philip John
    • DEV MAN’s Apprentice

    Hiya!

    That means that the user account to which you are logged in does not have permission to create new tables.

    You will need to grant that privilege to the MySQL user.

    If you're not sure of that you should speak to your hosting provider who'll be able to help with.

    Thanks,
    Phil

  • ardentwire
    • WPMU DEV Initiate

    I've fixed that. thanks.

    when I run "start the copy pocess" on the move-blog.php, i got this error message:

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/misiedum/public_html/v1/wp-content/move-blogs.php on line 140

    Warning: mysql_free_result(): supplied argument is not a valid MySQL result resource in /home/misiedum/public_html/v1/wp-content/move-blogs.php on line 141

    But it seems that the tables have been created succcessfully.

  • Philip John
    • DEV MAN’s Apprentice

    I run the script on single wordpress installation, not multisite. i plan on activating the multisite after installing multi-db. is it ok? Will it works as we expected?

    No, as per the plugin page Multi-DB is not compatible with single installs. It can only be used with Multisite.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.