Cannot save theme - Failed to load sprite in Builder

Hi, suddenly all my websites cannot save the theme in Builder. In all of them I get a pop-up background which prevents me from making a selection whether the theme should be activated or not. And that's it, it freezes like that. See screenshot below.

I also found out what is the problem: Builder is incorrectly referencing the image:
It expects it to be in [Domain.com]/themes/upfront/img/uf-ui-sprite.svg, in reality everything would be in [Domain.com]/wp-content/themes/upfront/img/uf-ui-sprite.svg, as you can see in this screenshot:

Please fix or tell me how to fix as I cannot do anything at the moment in any of my websites.

Regards,

Georgi

  • kr3t3n

    I guess this is a bug in the latest update. I noticed some GUI changes (what I saw is in the "Add link" to Image draggable element context menu, new icons, etc.) and I guess this was just neglected by the developers.

    Please run a thorough check of your code for invalid links and references and this makes it impossible to use the product. I don't know if this is the only place where this kind of bug has happened in this update (or in previous versions).

    If the problem is actually on my side, please let me know what I'm doing wrong and how to fix.
    If you need control to my admin, I will grant it, just let me know.

    P.S. Can you introduce an "autosave" option that can be disabled in settings and when enabled will make a background copy of the current layout progress every 30 (customizable) minutes? That way if browser session expires, something happens, whatever, the developer can still roll back to something other than scratch.

    Regards,

    Georgi

  • Kasia Swiderska

    Hello Georgi,

    I tested this on my site and indeed its bug, but has nothing to do with missing image (404 errors on images are not causing that type of issues).
    Looks like Upfront update mixed some z-index values and that's why layer is over the popup.
    I tested on my sites and this CSS

    #upfront-popup.getting-started-popup {z-index: 100011440;}

    should temporary fix the issue. I used this plugin to add it https://wordpress.org/plugins/simple-custom-css/

    I reported this to devs they are checking it because apparently there is problem with replicating this.

    As for the autosave I saw it was heavily discussed in the past by developers so it might be introduced in some future versions.

    kind regards,
    Kasia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.