Cannot upgrade from an old version of Marketpress to a new version

I'm having trouble upgrading my old version of market press to the new version I just purchased. It says I have the latest version and it cannot be upgraded, but I still have the old version. Can someone please help me find the best way to get around this and get my store updated to the new market press plugin?