Can't access settings for mailchimp sync

I've activated the Mailchimp plugin, but when I click settings I get the following:

The mindfulness-exercises.net page isn’t working

mindfulness-exercises.net is currently unable to handle this request.
HTTP ERROR 500

Not sure where to go from here.

  • Adam Czajczyk
    • Support Gorilla

    Hello ME Admin,

    I hope you're well today and thank you for your question!

    I think you're using the plugin on your Multisite WP install, is that correct? I tried to replicate the issue on my own test setup but I wasn't able to. Having said that, I'd like to take a closer look at your site.

    Could you please grant me a support access to your site so I could examine its settings and also investigate the issue? You may do this using our WPMU DEV Dashboard plugin by following this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Best regards,
    Adam

  • Milan
    • WordPress Wizard

    Hello ej,

    Hope you are well today and thanks for granting us staff access. :slight_smile:

    I just took a look at your site's setup and was able to replicate on your end. I followed each steps cleary on my end but no luck. I am not able to replicate this issue on my sandbox multisite environement. Hence this first seemed me plugin conflict, but unfortunatly that is not the case. After disabling all the plugins on your site( just for a moment, now each one of which were active before are active now :slight_smile: ), issue was still there.

    So that forcing me to believe that there is something else which I am not able to see it in first place. So I think we need to call WordPress debug mode agent here. :slight_smile:

    Just open your wp-config.php file and add this line in it, replacing define( "WP_DEBUG", false ) .

    define( "WP_DEBUG", true );
    define( "WP_DEBUG_LOG", true );
    define ( "WP_DEBUG_DISPLAY", false );

    After this process, try to visit MailChimp setting page one more time, if there is any error for that page, WordPress system will log it in file called debug.log and store is inside /wp-content/ directory of your site. Please attach that file in your next post so that I can see what's going on behind the scene here. :slight_smile:

    Looking forward to hearing back.
    Cheers,
    Milan

  • ME Admin
    • The Crimson Coder

    hopefully this works.. if not.. i've pasted below what's in that file

    [16-May-2016 14:56:41 UTC] PHP Fatal error: Cannot redeclare class Mailchimp_Folders in .../public_html/mindfulness-exercises.net/wp-content/plugins/mailchimp-sync/mailchimp-api/Mailchimp/Folders.php on line 3

  • Adam Czajczyk
    • Support Gorilla

    Hello ME Admin,

    Thank you for sharing this.

    The log file suggests that there's a conflict that's caused by the same class "Mailchimp_Folders" used more than once. I noticed that there's also another MailChimp related plugin (Easy Forms for MailChimp) installed on your site, there's a Divi theme enabled (and it's able to use MailChimp as well natively) and also on one of the sub-sites the Membership 2 Pro plugin is running with MailChimp Integration add-on enabled.

    I tried to replicate similar setup on my own Multisite test install but still wasn't able to replicate that behavior. I think though that this is the right direction. However, since I wasn't able to replicate this (including even duplicating the site with Multisite Clone Duplicator plugin) I'd like to ask you to perform a full theme/plugin conflict test as described on a flowchart in this article:

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    I hope that this would help us identify which plugin/theme (or at least which sub-site) is causing this conflict. Would you please give it a try and let me know of the result?

    Best regards,
    Adam

  • ME Admin
    • The Crimson Coder

    Thanks for this.. got it going..

    I deactivated Easy Forms for MailChimp on the main site and subsite and was able to access the settings for mailchimp sync. So it's definitely that plugin causing the conflict. I also noticed leaving the add-on for Membership2 pro is OK.. I can still get in the settings.

    I am curious what does this.. Allow shortcode use in all subsites options do in the mailchimp settings? what shortcode?

    Thanks for your help, we will take a closer look on our end and decide if we need that Easy Forms, looks like its one or the other at this point but not both.

  • Milan
    • WordPress Wizard

    Hello ME Admin

    Hope you are well today and thanks for asking us. :slight_smile:

    I am curious what does this.. Allow shortcode use in all subsites options do in the mailchimp settings? what shortcode?

    Actually when you enable option saying Allow shortcode use in all subsites, your every subsite's WYSWYG editor gets icon for generating different MailChimp shortcodes. :slight_smile: Please take a look at this screenshot.

    This option let's you set its visibility on your subsite. :slight_smile:

    Hope this helps. :slight_smile:
    Cheers,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.