Can't add a new Snapshot backup

Hi there.

I'm getting an error message when creating a new Snapshot of the entire website and/or Database. Please check the attached screenshot.

Any suggestions? Thanks!

  • Michael Bissett

    Hey Urbano, Michael here! :slight_smile:

    Got a few questions for you on this:

    #1: Is it only giving you this error you backup everything (the database, as well as the files), or is it also doing it when only specific items are backed up (e.g. only media files, or only plugins, or only specific database tables)?

    #2: Inside your site's Dashboard, if you go to:

    WPMU DEV -> Support -> System Info

    What's the value for "max_execution_time" in the PHP tab? I'd advise trying to increase that to a value like 300, you'll want to contact your host to check if they allow for increasing this value.

    #3: Inside of:

    Snapshot -> Settings

    What's the memory limit there? If it's set to 256M, I'd advise increasing it to 512M. That, and I'd advise trying to change the compression method, via the "
    Select Compression Option" setting at the bottom of the page.

    Kind Regards,
    Michael

    • Urbano

      Hey Michael, thank's for your reply.

      #1: Is it only giving you this error you backup everything (the database, as well as the files), or is it also doing it when only specific items are backed up (e.g. only media files, or only plugins, or only specific database tables)?

      I've tried to make a Snapshot of Database and Files separated and the error is the same.

      What's the value for "max_execution_time" in the PHP tab? I'd advise trying to increase that to a value like 300, you'll want to contact your host to check if they allow for increasing this value.

      Max Execution Time is 120, I don't think we're able to change that since the website is at SiteGround's Shared Hosting. Weird thing is, I was able to create snapshots successfully a couple of weeks ago.

      What's the memory limit there? If it's set to 256M, I'd advise increasing it to 512M. That, and I'd advise trying to change the compression method, via the "
      Select Compression Option" setting at the bottom of the page.

      I've changed to 512M and Compression to ZipArchive, unfortunately the error persists.

      Any suggestions? :slight_frown:

  • Michael Bissett

    Hey Urbano,

    Odd, I'm not seeing that Support Access is enabled for the site. Could you please send in the following via our secure contact form instead:

    - Mark to my attention, the subject line should contain only: ATTN: Michael Bissett
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress admin access details (login address, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    https://premium.wpmudev.org/contact/

    Thanks! :slight_smile:

    Kind Regards,
    Michael

  • Tyler Postle

    Hey Urbano,

    Apologies for our delay this time. Michael is no longer with the company and I just saw this ticket hadn't been responded to yet. Are you still experiencing this issue?

    I tried the credentials that you sent to Michael; however, it gave me password incorrect error.

    You could also just grant support access via our dashboard, then we can have a closer look.

    You can grant support access via WPMU DEV > Support > Grant Support Access.

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    My guess here is that you either have a ton of images or a lot of plugins and themes and it's causing a timeout or hitting a memory usage limit.

    Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle

    Hey Urbano,

    Thanks for granting support access. I had a look and looks like the issue is all your images. Your server must be running out of memory or timing out before it completes.

    I ran a snapshot with everything except your images and that seems to have worked fine.

    If you contact SiteGround then they may be able to up your limits, they'll likely see in your error logs what the issue is too.

    You can also send in your FTP to us and we can double check the logs to make sure but ultimately it will likely need to be your web host that ups the server limits if you're not able too.

    You can send that privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me.

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Look forward to hearing back!

    Cheers,
    Tyler

  • Tyler Postle

    Hey Urbano, no problem! Good to see ya again.

    After trying to do a snapshot, check your servers error log, which is usually in the root folder or you can view it from your cPanel.

    That should let you know what error was hit. It's likely the max_execution_time since your WP Memory limit is at 512mb according to your post further up.

    Sounds like you may have added more or bigger plugins since last time so it's now timing out on the plugins instead of images.

    Either way the error log should be able to confirm what it is. If you're unsure where to find the error log then just ask SiteGround :slight_smile:

    Cheers,
    Tyler