Can't Add Rules to Access Levels

I can't update or edit any access levels in my Membership plugin. I recently updated from 2.1.4 to 3.4.2 this morning, along with updating to WP 3.5.

There are no rules to drag and drop from the side. I have rules in old access levels from before the update. But I am reorganizing how the website gives content from negative rules to positive rules.

I'm not running on an SSL server, so no https.

Troubleshooting I've done:
Update from inside Plugins page on website
Download manually, update manually through FTP.
Deactivate and Reactivate plugin
Inspect with Firebug and looked for Javascript errors in the console. None.

I'm attaching a screenshot.

  • Patrick
    • Support Monkey

    Hiya @MediaBridges

    2 things to note:

    1.) It appears that your update to WordPress 3.5 is faulty, or you... oops... forgot to do it.

    2.) In the Membership Options, go to the "Advnaced" and click "Verify Membership Tables". If any are flagged, click "Repair Membership Tables". Then check your subscription area again.

    Also, you may more going on than you think: I tried to visit your site but the page wouldn't load at all at http://www.mediabridges.org

  • MediaBridges
    • Flash Drive

    Patrick, thank you for the quick response.

    1) WordPress Dashboard said I had 3.5. But, I re-installed WordPress per instructions on wordpress.org. I did this manually, not through the automatic update. I was asked the first time I installed 3.5 to update the database, did it then, and was not asked a second time. Can you check if the update is good? How did you do that?

    2)I verified the tables and found one missing - the coupon table. Everything else was okay. I repaired the tables to fix the missing table problem.

    3) We are with a local hosting company. They did a server update of their own at that moment. We were down for about 15 minutes. We are back up and running.

    Still don't see the rules to drag and drop.

  • Patrick
    • Support Monkey

    Hi again @MediaBridges

    Can you check if the update is good? How did you do that?

    Simply by viewing the source code of any page on your site, you can see what version of WordPress your site is running. It still says v3.4.2.

    And I can also see that you're still running Membership 2.1.4

    If your host was upgrading their servers at the same time as you were installing things, the cause of your problems is likely right there.

    I have 3 recommendations:

    1. Contact your host to see if they can provide any insight.
    2. Delete your current install and reinstall everything from scratch (ouch, I know)
    3. This one may hurt even more: switch to a better host.

  • MediaBridges
    • Flash Drive

    I appreciate the help. I had to reinstall WP 3.4.2 and Membership 2.1.4 last night because I received a phone call from work about permissions not working on the site correctly. I couldn't do anything more until I got in this morning, and of course, heh, you looked at the site then. :stuck_out_tongue:

    But yes, finally had updated to 3.5 correctly (checked in the source code) and up to membership 3.4.2.

    Then I did a second deactivation and reactivation for plugins, since now everything was installed correctly. Found the plugin causing my pain!

    The My Mail plugin from Code Canyon for some reason blocks the rules to in the access level.

    Unfortunately, we need this plugin to send out newsletters. But I can deactivate it to make my rule changes and turn it back on.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.