Can't Add Students to Course

Another problem with CoursePress Pro 2.

I cannot seem to add an existing user as a student on one of our courses. When I go to add a student, I select the user, and hit Add Student. It refreshes the page, and the student count does not change, nor does the student show up in the list. Also, they aren't able to log into WP at all.

Tagging Kasia Swiderska, as Kasia was working on a different problem with the plugin update.

  • Dimitris

    Hey there Paul,

    hope you're doing good today! Kasia isn't available at the moment so please allow me jump in here! :slight_smile:

    This is definitely a situation that can't be reproduced in my test environments as I just re-tested adding an existing user as student to a course.

    I can see the issue in action when I try to add a new dummy user that I created in
    /wp-admin/post.php?post=210&action=edit&tab=students
    This is the course in question, is that right?

    First I tried to see if there's a limit class number set but there's none, at least this is what I see despite that the course setup page is blur. :thinking:
    Please correct me if there's a limit indeed and there's an issue with course setup screen.

    Secondly, I'd like to make couple of changes in order to retest this:

    1. Get rid of some mixed-content errors that's show in console, like this:

    Mixed Content: The page at 'https://*****.*****.com/wp-admin/post.php?post=1914&action=edit&tab=students' was loaded over HTTPS, but requested an insecure image 'http://*****.*****.com/wp-content/plugins/shortcodes-ultimate-maker/assets/images/demo-1.png'. This content should also be served over HTTPS.

    Just try to deactivate the "shortcodes-ultimate-maker" plugin as long as you perform this test.

    2. Increase PHP memory allocated to WP and activate WP_DEBUG.
    Simply access your server through FTP, edit the wp-config.php file, find a line like
    define('WP_DEBUG', false);
    and replace it with the following (if the above line doesn’t exist, simply insert next snippet just above the /* That's all, stop editing! Happy blogging. */ comment)

    define('WP_MEMORY_LIMIT', '256M');
    
    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors', 0);

    References:
    https://premium.wpmudev.org/blog/increase-memory-limit/
    https://premium.wpmudev.org/blog/debugging-wordpress-how-to-use-wp_debug/

    Then go ahead and try to replicate the error by adding a student to the course.
    By doing so, a /wp-content/debug.log file should be created.
    Simply download it, rename it to debug.txt and attach it here in your next reply.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.