Can't assign roles to membership types, various errors

Hi, I would like to make a community website with membership types and give them special rights. I thought that the easiest way of doing this would be of assigning WP roles to membership types. But I can't as I get error messages.
I also had a lot of errors when activating the simulation mode, making my back-end completely inaccessible. I found a way to reset the access, but the simulation mode is still problematic.
Can somebody help?

  • Rupok
    • Support Ninja

    Hi Manohar,

    Sorry for the inconvenience you are having. I tried to regenerate this user role assign issue on my test site but I could not. So this is your site specific issue.

    Can you please check if you have debug display enabled on your site? To fix that, please login to your server with any FTP application like FileZilla and go to the root folder of your site. There you will see a file named "wp-config.php". Open that file and look for this line:
    define( 'WP_DEBUG_DISPLAY', true );
    Please replace that line with the following:
    define( 'WP_DEBUG_DISPLAY', false );
    Save and then check if this issue is gone.

    If not, can you please do a plugin conflict test just to make sure no other plugin is causing this? To know more about plugin conflict test, you can check this guide: Please let us know the result.

    I also could use Simulation Mode without any issue. Turning off debug display should fix this issue too I believe but I could tell you better about the issue if I could see it live, check your current configuration and make some tests on your site. Would you mind allowing Support Access so we can have a closer look at this?

    To enable support access you can follow this guide here:

    Please confirm here after you have tried all these I suggested above and if nothing helps, then confirm when you are done with granting Support Access. I'm looking forward to hearing from you and resolving this issue as soon as possible.

    Have a nice day. Cheers!

  • Manohar
    • Design Lord, Child of Thor

    Thank you Rupok for your help,

    I didn't find the line define( 'WP_DEBUG_DISPLAY', true ); in my wp-confic file, but I added define( 'WP_DEBUG_DISPLAY', false ); to see if it had any effect. Unfortunately it didn't work.
    I also performed a compatibility test with the rest of the plugins and themes, no help.

    I can gladly give you suport access. I have activated it from the WPMU dev dashbard and given the link of this thread for info.
    Coul you take a look at that? Do I need to do something else on my side?

    Thank you again for your help, see you!

  • Kasia Swiderska
    • Support nomad

    Hello Manohar,

    I'm afraid I'm not able to access your network because of issue with simulation mode. Did you manage to turn it off?
    I found solution for that on multisite here

    Can you check that and let me know if this will help with that?

    Also I would like to explain how the User Capabilities add-on works - because its descriptio might be misleading. That add-on will not change role of the user. It will add all capabilities from role you selected and will add it to user. So role will be still subscriber, but with capabilities of the author for example.

    kind regards,

  • Manohar
    • Design Lord, Child of Thor

    Hi Kasia,

    Thank you for the assistance. I was going to try to create a new administrator account and terminate the simulation problem, but I discovered another issue. The user page, both on the site options and the site dasboard doesn't show the users list. I can't change their status and I can't create new users! The option to chose between subscriber and administrator doesn't work as well!

    Here is a screenshot.

  • Nithin
    • Support Wizard

    Hey Manohar,

    This is really odd, just to be sure, do you still get the same issue, if you deactivate all the plugins in your system? To troubleshoot this further, I would like to check your websites configuration, could you please enable support access, so that we could give a closer look.

    You can grant access from WPMU DEV > Support > Support Access > Grant Access, or check this manual:

    Please let us know once you enable access, so that we could get this sorted. Have a nice day. :slight_smile:

    Kind Regards,

  • Manohar
    • Design Lord, Child of Thor

    Hello Nitin,

    Thank you for the tip. I tried to see if deactivating the plugins made any difference, but it didn't. THe problem persists.
    I just activated the remote support access. You should have access until January 21st.

    Let me know if you find a possible solution or if you need some other kind of access (FTP, PHPMyAdmin).

    Thank you for the help,

  • Kasia Swiderska
    • Support nomad

    Hello Manohar,

    Could you please send in the following via our secure contact form so I can check the debug log :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include WordPress network admin access details (login address, username & password)
    - Include FTP log-in details (hostname, username & password)
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    Please confirm in thread that you send those credentials

    kind regards,

  • Manohar
    • Design Lord, Child of Thor

    PS: Since this is a site in deveopment I'm also ok with backing up the main pages and delete the current site and remake it. Tabula rasa. With your help of course, if we can't find other solutions.
    The important work I've done so far is in fact the design on the pages, the rest could be easier to reset.

    But please, let me know before doing any important modification, thank you!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.