Can't change Network sub intro post text on not-logged-in homepage

Under Appearance > Theme Options > Homepage Settings I edited ‘Your Network sub intro post text’. This has changed the text on every page and post except for the homepage that not-logged-in visitors see. Where can I change that? It seems like lots of people don't want this to appear at all (myself included). Will there be an update to the theme which allows you to switch it off without installing and editing the Child Theme?

I don't think it's related but the Widgets in footer-2 and footer-4 are also not showing on the not-logged-in homepage but do appear everywhere else. The Widget in footer-1 appears fine! I'm not sure how to correct this.

Thanks very much

Frances @PCI Team

  • Jack Kitterhing

    Hi there Frances,

    Hope you're well today and thanks for your question.

    There are a couple of places here that this needs to be edited.

    You have the network sub intro setting in appearance > theme options > homepage settings.

    And then you have Insert Your Services Intro text in appearance > theme options > service settings (that is the one for the homepage.

    The widgets out of the box aren't based on user logged in or not logged in, I have checked your site (logged out) and see

    Sign up for our Newsletter, About performance consultants, tweets and contact us, is that correct? :slight_smile:

    Thanks!

    Kind Regards
    Jack.

  • PCI Team

    Hello Jack

    Am enjoying a rare sunny day, thanks. And all the better for your rapid and helpful response, thank you. The widgets you see on the visitor home page are correct and I see that now they are correct this morning on my browser too. Last night I refreshed page and deleted browsing history but the widgets just wouldn't appear on the home page. Oddly enough, the sub intro post text has also corrected itself since last night, without my having to amend the Services Intro text in appearance > theme options > service settings (but very I'm glad to know that it is there in case I need to change it in future). So in the end, it seems the problems were related, ie just that the home page is slower to update than the rest of the site. I was viewing the visitor home page in IE8 because I'm testing a login problem we're having from IE8.

    And on that subject, I see that you are a Code Monkey. Yippee. And an expert on Blogs MU? I wonder if you're able to help me discover what is causing our site to crash when you log in from IE8. We're going to be running a training this month and the participants only have access to IE8 at work, so I need to fix the problem quickly so they can log in and view the learning support materials in their workplace.

    The original post topic was 'Can I make my site compatible with Internet Explorer 8' (https://premium.wpmudev.org/forums/topic/can-i-make-my-site-compatible-with-internet-explorer-8) but the important details of the tests I have run are here:
    https://premium.wpmudev.org/forums/topic/if-i-switch-theme-will-the-menus-widgets-etc-be-retained

    Thanks very much for your help!

    Frances @PCI Team

  • Jack Kitterhing

    Hi there Frances,

    Thanks for the additional information and I'm glad to hear you have those issues resolved :slight_smile:

    On the login issue, I have just checked over both the threads and that is certainly strange, would you mind if I created a few test accounts please to check this?

    Out of interest was compatibility mode enabled in IE 8 for testing? Which O/S is this? Do you know which service pack was installed?

    Thanks!

    Kind Regards
    Jack.

  • PCI Team

    Ooh, thank you very much for looking into this. Yes please create test accounts (or do I need to do that for you?) Over the weekend I have been running my IE8 tests on Windows Vista Business. However, my colleague has the same trouble with IE8 on Windows 7 Professional and the client uses Windows 7 operating system Internet version 8.

    I don't know what compatibility mode is, so no it probably wasn't enabled. But having looked at what 'program compatibility' is, I don't think it was needed.

    What is the service pack? On WordPress, Blogs MU or Windows?

    Kind regards

    Frances @PCI Team

  • PCI Team

    Hello Jack

    Thanks for testing. Are you using a real or virtual IE8? And did you wait for the page to fully load? In my experience it doesn't crash immediately.

    I was very excited to hear you could log in but sadly I just asked someone else to test and he reports that on every page it loads, then starts loading again but never finishes loading. He says we have a script which starts running after page load and will probably cause a stack overflow (a memory leak) if left to keep running. He identifies it as Twitter widget and modernizr. (I tried turning the Twitter widget off in my earlier tests and it didn't stop my IE8 from crashing). Interestingly, he says the version of modernizr is very old (amusing!). How do I turn off or update modernizr?

    He also says that it looks like access is denied to some scripts, so I need to check file permissions on the server. This could be the server host or permissions within cms for logged in users. The latter sounds like it could reveal something because the browser only crashes if you log in and not if you don't. How do I go about checking the permissions within cms?

    He ran the test on
    IE Version 8.0.7600.16385 with compatibility mode on (I understand this mimics IE7 and doesn't crash browser)
    Windows 7 enterprise

    With thanks and best wishes

    Frances

  • PCI Team

    Hi Jack

    Have emailed what I think you need.

    The other thing I’m wondering is that when I tried the site with Buddy Corporate it didn’t cause IE8 to crash when you log in (just made the site look terrible). Do you think I could do something as simple as copy the modernizr.js file from that theme and replace the file in the Blogs Mu theme that we are using?

    Best wishes

    Frances

  • PCI Team

    Hello Jack

    I had exactly the same thought because of the way the custom login page loaded so slowly (and says 'Done but with errors on page' if you're using IE8) but unfortunately when I tested IE8 logging in from wp-login.php in my previous tests (and repeated today), you get the same problem as you do when logging in from the custom login template, ie the next page appears to be loading well and then crashes.

    This time, I also deactivated the Twitter widget again just in case I hadn't done it in combination with wp-login.php before but it didn't help.

    Did you find anything unusual with the permissions for logged-in users? The logged-in versus not-logged in status must be a key factor because you can browse all our Visitor pages on IE8. It's only when you log in that trouble arises.

    On the matter of the errors when loading the custom login page, modernizr.js pops up again. The report I get when visiting the custom /login page on IE8 is as follows:

    'c.body' is null or not an object
    modernizr.js Line: 4
    Expected identified, string or number
    login Line: 125
    Code: 0 Char: 5

    If I remove the Twitter widget, the first two lines of the error message disappear. So, modernizr.js and Twitter scripts are in a battle! Can the Twitter widget cause modernizr.js script to run after the pages load, and cause the pages to keep loading in IE8? I don't think this is what causes the pages to crash but it would be nice to fix if we can. Can I tweak the Twitter script (see below) or is it the way that the widget is coded or referenced in Blogs MU that is causing the problem?

    The code is as follows (I removed the opening and closing <> so it is not read as html here):

    a class="twitter-timeline" data-dnt="true" target="_blank" href="https://twitter.com/PCIntl" data-widget-id="XXXXXXXXXXXXXXXXXX">Tweets by @PCIntl
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:disappointed:.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script

    Or is it simply a matter that the twitter feed comes via https and our site is http? I'm told that might cause a problem for IE8.

    Thanks again for all your help

    Best wishes

    Frances

  • PCI Team

    Hi Jack

    Were you able to run any tests? I'm thinking that if the user logged-in permissions don't reveal anything, should I try a process of elimination by removing the reference to each javascript file in turn? I've deactivated the Twitter widget so I assume that sorts the Twitter script but I don't know which template(s) I need to edit to test all the other javascripts. Please could you point me in the right direction.

    In theory, the site is supposed to be ready for login via Internet Explorer 8 tomorrow!!!

    Thanks very much

    Frances

  • PCI Team

    Hi Jack

    Help, help! I'm up against the clock now. If you haven't spotted anything else and if you don't think it's worth my following a process of elimination by deleting references to js files (which folder and which file would I have to look at if I did?), then as a last resort, I think we should force Internet Explorer 8 into Internet Explorer 7 mode. I have tried logging in from IE8 in compatibility mode and was successful, so if we can force IE8 into IE7 then I'm hoping everything will be OK.

    I'm told that I need to stick the following just after the <head> tag:

    <!--[if IE 8 ]> <meta http-equiv="X-UA-Compatible" content="IE-EmulateIE7" /> <![endif]-->

    Does it need to apply right across the site or just the login or home page? Please could you tell me in which template(s) (in which folder(s)) I have to put the code to make sure it works.

    Thank you for your help

    Best wishes

    Frances

  • PCI Team

    Hello Jack

    Thanks for pointing me to the right file. Frustratingly, it doesn't seem to have worked. The code now looks as follows:

    <!DOCTYPE html>
    <!--[if lt IE 7 ]> <html lang="en" class="no-js ie6"> <![endif]-->
    <!--[if IE 7 ]> <html lang="en" class="no-js ie7"> <![endif]-->
    <!--[if IE 8 ]> <html lang="en" class="no-js ie8"> <![endif]-->
    <!--[if IE 9 ]> <html lang="en" class="no-js ie9"> <![endif]-->
    <!--[if (gt IE 9)|!(IE)]><!--> <html <?php language_attributes(); ?> class="no-js"> <!--<![endif]-->
    <head>
    <!--[if IE 8 ]> <meta http-equiv="X-UA-Compatible" content="IE-EmulateIE7" /> <![endif]-->
    <meta charset="<?php bloginfo( 'charset' ); ?>" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="profile" target="_blank" href="http://gmpg.org/xfn/11">
    <?php include ( TEMPLATEPATH . '/options-var.php' ); ?>

    Do you think it should go after the first <!—[if IE 8…. line? Or even somehow be added to that code so it receives the instruction together? Or perhaps replace it completely, and put it before the [if IE 7 code since it should then be behaving as IE 7 or not really?

    Many thanks

    Frances

  • PCI Team

    Do we have to have all the conditionals before <head> and what do they do? I see that for IE7 there is <!--[if lt IE 7 ]> and <!--[if IE 7 ]>. And for IE9 there is <!--[if IE 9 ]> and <!--[if (gt IE 9)|!(IE)]> but there is only one conditional for IE8 (before I added mine). Is there another type of IE8 browser that we need to be coding for here?

    And I read that conditional comment causes all following X-UA-Compatible declarations to be ignored.

    Could I use something like the following:

    <meta http-equiv="X-UA-Compatible" content="IE=7; IE=9; IE=10; IE=11" />

    so that IE8 becomes IE7 and all the others stay as they are? And if so, do I put it before the conditionals?

  • PCI Team

    Hi Jack

    Many thanks for trying to help. After lots of time spent changing themes, removing widgets and plugins, reinstalling widgets and plugins, looking at cookies, hunting through code for errors and trying to add code to the header.php to force IE8 into IE7, we finally resolved this on Sunday. Not knowing how to do it myself, I paid someone to update the Blogs MU modernizer to the latest available (2.7.1 I think) and now it works perfectly.

    I am what I think you class 'a beginner' and therefore did not know how to diagnose the problem. So, I had to pay a professional. A reminder of the diagnosis:

    - - - - -
    On every page it loads, then starts loading again, but never finishes loading. You have a script which starts running after page load and will probably cause a stack overflow if left to keep running

    Twitter widget and modernizr.
    Your version of modernizr is very old
    I can get in using compatibility mode
    - - - - -

    I removed the Twitter widget but that did not solve the problem. I could also log in by manually switching to compatibility mode but was unsuccessful in trying to force IE8 to IE7, even following your final instruction (the only page that is in compatibility view is the custom login page, so perhaps the code is needed elsewhere and not just in header.php?).

    It was only once the modernizr was replaced that IE8 stopped crashing on login. I hope that you will be able to feed this information back to the Blogs MU developers.

    Many thanks again for trying to help.

    With best wishes

    Frances

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.