Can't create blog on Multisite

Hi,

I have multisite on my blogging community and I have enabled "All Users Can Create Blogs" in my Network Settings, but it is so strange that there are no options for members to create blogs when they login. How to resolve that? Also, are there any ways to 1) force every registered members to have at least one blog 2) force everyone to have a blog on registration ?
Thank you.

  • Predrag Dubajic
    • Support

    Hi Sarah,

    When there's a user without a site you can point them to yourdomain.com/wp-admin/my-sites.php or yourdomain.com/wp-signup.com where they can create new sites with their account.

    About forcing the users to create site, since Create Site is default option when registering new account what you can do is simply hide those fields via CSS, that way they will not show on your site but it will still be selected option and users will be prompted to create site during registration by default.
    Would this work for you?

    Cheers,
    Predrag

  • Dutchman
    • The Bug Hunter

    Hi Sarah,

    Just to make sure we have the same scenario in mind. Is it a standard setup that you just installed or an existing network that used to work? Also do you have any plugins enabled that might interfere with memeber capabilitie options.

    One time I setup my network with Membership pro 2 enabled but not configured properly, so even with "user can create blogs" enabled, no option to create a site was available. Nor with registration, nor with "create site " on the blog directory page.

    Cheers.

  • Adam Czajczyk
    • Support Gorilla

    Hello Dutchman!

    The Membership 2 Pro plugin should not interfere with ability to create blogs as it's affecting the user registration. Registered user then should be able to create blogs if that is allowed in your WordPress options. That is, unless the Membership 2 Pro protection rules are setup to somehow limit that.

    I suppose though that this may be a different issue and I would like to take a closer look at your setup. Could you please grant me a support access to your site so I could check it? To do this, please follow this guide:

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    I also moved your question from the "Members" forum to the Support forum so we could be able to access the site and help you. I hope you don't mind that :slight_smile:

    Best regards,
    Adam

  • Milan
    • WordPress Wizard

    Hello Dutchman

    Hope you are well today and won't mind me chiming here. :slight_smile:

    Just for good support ticket advise, :wink: its always good that you start new thread at our support forum for your any issue or query. Posting in other member's thread creates confusion and delay among staff and members. Please take is lightly, I just wanted to make sure you know about this. :slight_smile:

    Kind Regards,
    Milan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.