Can't create/save Units in CoursePress 2.0.1

I upgraded CoursePress Pro from 1.x to 2.0.1 on a development site. Most of the plugins on this site are other WPMUDEV plugins, plus WooCommerce, Yoast, Beaver Builder page builder.

I was trying to save and add new units, but it's not working.

When adding new unit, the wheel just spins and nothing is added.
When trying to save existing unit, I get an error "Something went wrong. Unit was not saved!"

See attachment with screenshots of errors in Chrome console:

Are there any known issues right now with CoursePress Pro 2.0.1?

As a separate issue, I cannot dismiss "Install MarketPress plugin in order to sell courses" noticed. It keeps coming back after page reload.

Any help would be appreciated! I granted WPMUDEV support access to this website.

  • James Morris

    Hello v1ktor,

    I hope you are well today.

    I just tried to run some tests using the same plugins you are using, but was unable to reproduce the symptoms you are seeing. In order to help you better with your issue, would you please grant me access to your site and server?

    Please visit the Contact page and complete the form with the following information:

    Select "I have a different question" from the drop-down box.

    Subject: "Attn: James Morris"

    In the Message box, please provide the following:

    - link back to this thread for reference
    - any other relevant urls

    - Admin login:
    Admin username
    Admin password
    Login url

    - Hosting Control Panel Login
    Admin username
    Admin password
    Login url

    - FTP credentials
    host
    username
    password
    (and port if required)

    Best regards,

    James Morris

  • Panos

    Hi v1ktor ,

    Thanks for reporting this!

    We just had reported similar behavior by other members. It seems to be related to server configuration which don't allow the PUT method. Currently I have replaced file wp-content/plugins/coursepress/2.0/asset/js/coursepress-unitsbuilder.js which should be using POST for now.

    We would recommend that you contact your host about it and ask if possible to allow PUT. Also we have reported this to the devs to take it under consideration for next release.

    Please try saving units and let us know how it goes.

    Thanks!
    Panos

  • Panos

    Hi v1ktor ,

    it's impossible for PUT to be disabled otherwise site would not function correctly.

    Of this I understand that PUT is not disabled, so I am a bit confused here. So could you please clarify if it is indeed enabled, or that you should not enable it?

    I'm not familiar with nginx configuration, you could try overriding by adding following in .htaccess

    <Limit GET POST PUT DELETE>
    order deny,allow
    allow from all
    </Limit>

    You might find this helpful from nginx.org: http://nginx.org/en/docs/http/ngx_http_dav_module.html

    Could also confirm if the workaround described on my previous post works on your side?

    Best wishes and merry Christmas!
    Panos

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.