Can't delete service provider

Hakan,

I can't get rid of two service providers (super administrator "praktijk") see pic #1

There is a strange output on general settings tab. Should I ingnor it or is it an error? See pic #2

I can't find the place where I can translate "confirmed". Can't find it in po or mo.

If I open page appointments and the timeslots of today are passed, the page shows more timeslots then originally were opened. You can't select them tough. which is good of course. https://www.delloods.nl/vdw/afspraak. “Consult huisarts”.

Can you help me out please?
thanks Albert

pic #1 http://www.yuryyulan.nl/AppointmentPlus_Settings_Profs.jpg
pic #2 http://www.yuryyulan.nl/AppointmentPlus_Settings_General.jpg

  • PC

    Hello Albert,

    Greetings and thanks for posting on the forums.

    I can't get rid of two service providers (super administrator "praktijk":wink: see pic #1

    I see something strange in the plugin. I do not have Dummy option in the plugin settings. Did you make any custom modification to the plugin ?

    There is a strange output on general settings tab. Should I ingnor it or is it an error? See pic #2

    That should not be ignored, I am sure its coming due to some misconfiguration. Just check for a plugin conflict using the attached screenshot.

    If I open page appointments and the timeslots of today are passed, the page shows more timeslots then originally were opened. You can't select them tough. which is good of course. https://www.delloods.nl/vdw/afspraak. “Consult huisarts”.

    That is how it works. It will show all the dates of the calendar and will let you click only on those you selected as available.

    I can't find the place where I can translate "confirmed". Can't find it in po or mo.

    Which text are you trying to change ? Do you see that on the front end or the backend ? Please give a screenshot.

    Cheers, PC

  • albertmullaart

    Pranaya,
    Thanks for your input. Apart from Updating Appointments+ to version 1.2.2. I did what you suggested:

    There is no dummy active.
    I did not make any custom modification to any appointments+ file.
    I deactivated all plugins. Strange output is still in General settings tab.

    It doesn’t have any bad effects on the functionality as far as I can see, but it is strange.
    Anybody else who had this strange output in de general settings tab?

    Hakan,

    Thank you for your prompt response.

    I’m not sure if I was clear enough in stating my question. Maybe your answer is that this is solved in a new release or version. I try again to explain what I see:
    In the providers tab I want to remove the two providers “Praktijk”. “Praktijk” is the Super Admin. Removing the service in the providers tab and save, doesn’t work. I do can remove any other provider by setting them to “Select Service” and save.
    Appointments+ also will not accept that I change the Super Admin “Praktijk” to another provider.
    It is not possible to remove/disable/delete the Super Admin in WP. Anyway I can’t.

    I like to translate “confirmed” in the frontend (My appointments). nl_NL.mo file doesn't do the trick.

    How can I add extra fields from WP to appointment+ back end.
    I need to see the WP “display_name” and one or two other fields from WP in the back end, so the provider is able to check which “John Smith” logged in and made the appointment.

    I need some time (one or two working days) to confirm the appointment.
    How do I allow clients to make appointments starting on the day of tomorrow, or on the day after tomorrow?

    How can I show the “pending” appointments in front end “My appointments”, so the client can see that his appointment is submitted? (and: where do I translate “pending”?)

    Your input is much appreciated.
    Thanks, Albert

  • Hakan

    Hi,

    In the providers tab I want to remove the two providers “Praktijk”.

    In the providers list there are 2 “Praktijk” with ID's 8 and 12. One is super admin, you cannot delete it. The other one is a user which has been removed from this blog. Go to Network Admin>Users and delete that user there.

    How can I add extra fields from WP to appointment+ back end.

    You cannot. This is not supported at the moment.

    I need some time (one or two working days) to confirm the appointment.
    How do I allow clients to make appointments starting on the day of tomorrow, or on the day after tomorrow?

    Please see this thread to block current day or current day + next day:
    https://premium.wpmudev.org/forums/topic/24hr-ahead-booking-or-block-booking-on-current-day

    How can I show the “pending” appointments in front end “My appointments”, so the client can see that his appointment is submitted? (and: where do I translate “pending”?)

    Change my_appointments shortcode like this:

    [my_appointments status="paid,pending,confirmed"]

    Please see Shortcodes tab for different options.

    nl_NL.mo file doesn't do the trick.

    File name is like that? It should be appointments-nl_NL.mo

    After you have translated the appointments.pot file, create a localized file appointments-nl_NL.mo file using poedit and upload it to languages folder. PLUS you should select Dutch for that sub blog, if not already selected.

    Cheers,
    Hakan

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.