Can't display the product image

I'm creating my ow theme and can't display the product image on single product page I'm trying the_post_thumbnail also tried mp_product_image( true, 'list', $post->ID, 300, left)

  • Nithin
    • Support Wizard

    Hi Justa CoolGeek,

    Hope you are doing good today. :slight_smile:

    I just checked your website, and in your single product image, the image seems to appear. yourDomainURL/store/products/test2/

    Am I checking the right website? If it's in another website, you can use the default WordPress theme as a reference, and base your code in your new theme according to it.

    Please advise if I'm missing out anything, have a nice weekend. :slight_smile:

    Kind Regards,
    Nithin

  • Rupok
    • Support Ninja

    Hi Justa CoolGeek, hope you had a wonderful day.

    Thanks for granting Support Access. I checked the issue and found you have MarketPress and MOJO Marketplace both activated. Can you deactivate MOJO ecommerce plugin and check if the issue is gone?

    Did you change any MarketPress plugin template file? Can you please try with default MarketPress files? Can you please activate any default WordPress theme and check if the issue is still there?

    Please let us know in details. I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.