can't enable uptime monitor

I am running multisite, and getting this error when trying to enable uptime monitor.

It appears that your home_url setting is trying to redirect to another domain. This often happens when you are forcing https but haven't updated your site setting for that. Please verify that the home_url option of your WP install is correct, then click refresh updates in the Dashboard plugin.