Can't figure out how to get API info from PayPal.

1. I want to set up PayPal to accept payments with the Classifieds plugin, but the “instructions” page that I’m pointed to is WAY over my head. And I can’t find where to request an API in PayPal.

https://cms.paypal.com/us/cgi-bin/?cmd=_render-content&content_ID=developer/e_howto_api_ECAPICredentials

2. As the blog admin, I would like to be able to post classifieds to my own website at no cost, but the plugin indicates that it’s not possible to have both free and paid classifieds. Is there a way around this for me?

Thanks

Dave

  • David
    • WPMU DEV Initiate

    1. I tried to go to that URL, whiled logged into my PayPal account, but get a 404 error.

    2. Ok, but I tried changing my classifieds to “free listings” and then going to the Admin –> Classifieds –> Add New but I get a blank page with a “Cheatin’ uh?” message on it.

  • Timothy
    • Chief Pigeon

    Hey again.

    1.That’s odd, maybe because it’s for the UK.

    I’ve attached screenshots so you can see them.

    Take a look and let me know if you get those settings on your version of Paypal.

    2. You’re doing this with the admin role?

    And is it a direct link, or when you click?

    It works ok for me when I just tested.

    Let me know.

    Take care.

  • David
    • WPMU DEV Initiate

    1. I don’t see the screenshots….can you just give me the path you take after logging into PayPal to reach the API screen?

    2. Yes, I’m logged into my blog as an Admin, and clicking the “Create New Ad” button.

    This is the URL of the page where the “Cheatin’ uh?” error message appears:

    http://medellinliving.com/wp-admin/post-new.php?post_type=classifieds

    If necessary, I’m willing to set up a temp Admin account for you to see what I’m talking about. I tried clearing my browser cache too. I’m using Chrome.

  • Timothy
    • Chief Pigeon

    1. hmm, for some reason they didn't attach.

    To create an API signature:

    Log in to PayPal, then click Profile under My Account.

    Click My selling tools.

    Click API Access.

    Click Request API Credentials.

    Check Request API signature and click Agree and Submit.

    That's from the Paypal site.

    2. Can you please go into CustomPress and just resave the settings then try again?

    If that doesn't work please provide screenshots of the settings.

    If there isn't anything obvious and if needed I could then take a closer look for you. :slight_smile:

    Take care.

  • David
    • WPMU DEV Initiate

    1. Ok, I got the API info from PayPal.

    2. I hit “save” on the default settings on the “Custom Press” page but am still getting the same error. To be safe, I deactivated a different plugin I was using called “Capabilities Manager.”

  • Timothy
    • Chief Pigeon

    Hey again.

    1. Glad you found that! :slight_smile:

    2. Can you quickly check for conflicts by disabling all other plugins. If it still happens then send in your details.

    – Mark to my attention

    – Link back to this thread

    – Include admin/network access

    – Include FTP

    – Include any relevant URLS for your site

    On the contact form, select “I have a different question“, this ensures it comes through and gets assigned to me.

    https://premium.wpmudev.org/contact/

    Cheers.

  • David
    • WPMU DEV Initiate

    After deactivating and reactivating the Classfieds plugin, I noticed the default for the Admin role didn’t allow “View Classifieds” so I activated that, and now when I go to “Add New” I get the edit screen as expected.

    I’ll let you know if I run into the same problem again. I’m going to try posting my first (free) classified now.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.