Can't get Domain Mapping to map

Hi there,

I've set up a multisite installation at and created different sub-blogs on,, etc.

I've registered multiple domains etc. that I want to map to these subdomains.

Domain Mapping on multisite installation is installed correctly, within the sub-blogs admin panels I've set up the mapping.

However, when I check the domains, etc. I only get "parking pages" as if mapping would lead to nowhere.
When I ping the sample1, domains, I get the correct IP of, however.

Here are the exact specifications:

I've got a SEOhosting account with is on (dedicated IP), and of course so are the subdomains.

I've set up all domains to be mapped in Tools => Domain Mapping (on sub blogs)

I've tried pointing several domains from different registrars there: (registered with SEOhosing, but on a different IP (shared, not
=> Set up A-Record pointing to, doing an a record check seems fine (registered with
=> A-Record (@ and www) pointing to

3 different other domains (,,
=> tried pointing A-record to, tried setting up CNAME to

As nothing happened, I also tried setting
Super Admin => Sites => Edit => Site Info (Domain; both siteurl and home) to;
however, this does not seem to make any difference.

I'm getting crazy here... could somebody help pleaes?

I'd be happy to provide admin login for both WP as well as hosts (to a trusted developer / WPMUDEV member) to check this...

Thank you so much!