Can't Get Domain Mapping to Work

I have a VPS at WiredTree and use the same DNS numbers for all me domains. The A record is all set up for the domain that I am trying to map and when I add the domain to map to I get "needs revalidation" this is after checking "NO" in the setting under Verify domain's DNS settings.

I also started getting this error in my WP dashboard.

Warning: Cannot modify header information - headers already sent by (output started at /home/rbrhino/public_html/wp-config.php:1) in /home/rbrhino/public_html/wp-includes/option.php on line 750

Warning: Cannot modify header information - headers already sent by (output started at /home/rbrhino/public_html/wp-config.php:1) in /home/rbrhino/public_html/wp-includes/option.php on line 751

Any advise on fixing this?

Thanks

  • Michelle Shull

    Hey there, Rick!

    Via FTP, navigate to the root folder of your WordPress install. Download and open your wp-config.php file in a plain text editor.

    On line one, you're probably going to see a span of white space in front of your opening PHP tag. Remove that space.

    That will fix your headers already sent error. : )

    It may also fix your first issue, too, can you report back in after editing wp-config?

    Thanks, rick!

  • rick_billings7

    Thanks Michelle, yes moving the PHP tag back over fixed the code errors.

    But the domain is still not mapping. I now get under Health Status "invalid" .

    I have worked on this for over 2 hours trying everything I could think of even deleting the DNS Record for for my domain and adding it back. There is a A Record point to the IPS address.

    This IP addrerss for this domain and the WPMU site domain are the same is that ok. They are on the same VPS.

    Thanks,
    Rick

  • Tyler Postle

    Hey Rick,

    Hope you're doing well today and thanks for your question! Are you still having troubles here? I'm more than happy to help further.

    Have you tested your IP to ensure it's documentRoot is set correctly? If it is then when you navigate to it in your browser you should see your site.

    If you aren't seeing your site when visiting your IP then you will want to ask your host and they should be able to get that set correctly no problem :slight_smile:

    If that isn't the issue then do you mind sending in your FTP information so we can take a closer look?

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Look forward to hearing back Rick!

    All the best,
    Tyler

  • Tyler Postle

    Hey Rick,

    Thanks for sending the info in :slight_smile:

    I took a closer look and your IP address isn't pointing towards your WordPress installation, which is why the domain mapping isn't working.

    If you ask your host to set the DocumentRoot of your IP address so that your WordPress installation comes up when entering the IP into the address bar, then they should be able to easily assist with this.

    Once that is set then you shouldn't have any problems :slight_smile:

    Look forward to hearing back Rick!

    All the best,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.