Can't get domain mapping to work

Hi,

I have the following:

1 x domain bought from bluehost
1 x domain bought from godaddy

I've pointed the nameservers to cloudfare but am managing them through my hosting account at rochen. This is where I use cPanel to add A/Cname records.

I created a subdomain install but when trying to map a domain to it, I get the red box message.

Please help.

  • Rupok
    • Support Ninja

    Hi Anthony

    Hope you had a wonderful day.

    Do you have a dedicated IP for your server? I can't check it because your site is under Cloudflare.

    Let me give you summarized idea about how Domain Mapping works. First you need to have a dedicated IP for your server and it should point to your main site if anyone enters the IP in browser. For example, your dedicated IP is "1.1.1.1" and your main site is "master.com". So your server has to be set up in such a way that when anyone enter "1.1.1.1" in the browser, it will open "master.com".

    Now suppose, you have a subdomain "second.master.com" and you purchased a domain (lets say second.com). So you should create an A record in "second.com" DNS Settings pointing to your dedicated IP, so when someone goes to "second.com", they are pointed to "1.1.1.1" and it will eventually open "master.com".

    Now if you map your domain, it will work. Because when you will go to "second.com", it will take you to "master.com", and as the domain is mapped, "master.com" already knows which subsite to server as the request came from "second.com".

    Procedure is almost same if you are using Cloudflare. In that case, you add Cloudflare nameservers in your Domain Control Panel DNS, and then set the A record in "Cloudflare DNS Settings".

    Please let us know if you still have any confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Anthony
    • Site Builder, Child of Zeus

    Hi Rupok,

    Thanks for responding. I've already tried doing as you mentioned.

    I even tried buying a new domain off another registrar just to try this.

    I still can't get it to work.

    Could you please take a look? I tried to map sieusanpham.com to testcf.rocketwebber.com

    Thanks

  • Anthony
    • Site Builder, Child of Zeus

    Hi Ajay,

    I just added sieusanpham.com to cloudfare and changed the nameservers to cloudfare's. I had already added an A record before that and that points to the IP. I can't confirm the nameserver change has taken affect yet. Below are the DNS settings in cloudfare:

    A
    ftp points to 65.99.240.118 Automatic Delete
    A
    sieusanpham.com points to 65.99.240.118 Automatic Delete
    A
    www points to 65.99.240.118 Automatic Delete
    MX
    sieusanpham.com
    mail handled by mx00.1and1.com
    10 Automatic Delete
    MX
    sieusanpham.com
    mail handled by mx01.1and1.com
    11 Automatic

  • Kasia Swiderska
    • Support nomad

    Hello Anthony,

    Is it still not working? Could you again enable support access so we could have another look?
    Also could we have access to your cPanel where you have setup your domain?

    Could you please send in the following via our secure contact form https://premium.wpmudev.org/contact/ :

    - Mark to my attention, the subject line should contain only: ATTN: Kasia Swiderska
    - Do not include anything else in the subject line, doing so may delay our response due to how email filtering works.
    - Link back to this thread
    - Include cPanel credentials
    - Include any relevant URLs for your site

    IMPORTANT: Please make sure you select "I have a different question" for your topic, so it doesn't go back to the forums - this and the subject line ensure that it gets assigned to me.

    kind regards,
    Kasia

  • Rupok
    • Support Ninja

    Hi Anthony

    Hope you had a wonderful day.

    Thanks for sending details to Kasia Swiderska about your cPanel and CF account, but I could not find your WordPress Login Credentials through our Contact System. Can you please send us message with WP Login Credentials again in the same way so I can jump in right away?

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Anthony

    Hope you had a wonderful day.

    I do apologize for the long delay. I really want to resolve this issue as soon as we can.

    Just to facilitate the process, I'm summarizing all info we've got from you.
    # sieusanpham.com is the domain you are trying to map
    # testcf.rocketwebber.com is the subsite you are trying to point to
    # So rocketwebber.com is your main multisite
    At this point, I'm a bit confused. I got wp login credentials for rocketwebber.com and logged in. But that site seems to be a single WordPress site.

    Can you please confirm if I'm missing something? I'm looking forward to hear from you and resolve this issue as soon as possible.

    Have a nice day. Cheers!
    Rupok

  • Rupok
    • Support Ninja

    Hi Anthony

    Hope you had a wonderful day.

    I don't know why but now I can see all subsites. So I investigated further, seems like your domain control panel DNS is pointing to Cloudflare. That's fine. In Cloudflare DNS, you have added A record with "65.99.240.118", that's also perfect. So the only point left is opening up your main site when entering the IP. I mean, your server should be configured in such a way that when I enter "65.99.240.118" this in my browser, your main multisite should open. This is not happening. This is required, because the optimum process should be:
    1. You enter sieusanpham.com in your browser
    2. It will get nameservers from your domain control panel
    3. Nameservers will point it to cloudflare
    4. Cloudflare will point it to your server IP
    5. Your server IP will serve the main site
    6. Your main site will get the request from sieusanpham.com and as domain is already mapped, it will serve associated subsite for that domain.

    Up to step 4, everything is working perfectly. But then at step 5, it's stopping. Can you please talk to your host how you can serve your site when your server IP is entered in your browser? I believe, they can help. And as soon as this is done, you can map your domains without any problem I believe.

    If you are using cPanel in your server, you can also use Addon Domains and Parked Domains. They must point to the root of your multisite installation in order to function correctly.

    Please let us know if you still have confusion. We will be glad to help.

    Have a nice day. Cheers!
    Rupok

  • Anthony
    • Site Builder, Child of Zeus

    Hi Rupok,

    The support guy from my hosting was useless.

    I ended up finding the solution through another means. Ends up, ALL I had to do was add the domain as a parked domain.

    Such a simple solution that I wish I knew of 2 months ago.

    Either way, I appreciate you following up.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.