Can't get marketpress to recognise paypal IPN

I’ve been pulling my hair out for a few days now and have been through every thread on here I can find.

I am using marketpress on a single installation of wordpress – i.e. just a single cart.

I am using paypal sanbox. Both the sandbox user and sandbox owner of the business are using the same currency. Transactions are occuring, and payment being transfered correctly from paypal sanbox side of things.

but I can’t get marketpress to deal with paypal IPN data.

I have set the IPN notification URL in paypal itself.

I have put a mail function inside the process_ipn_return function so that I am emailed every time it is called.

If I go directly to the IPN notification URL then I get an email and the page loads saying that variables are missing. This is as I would expect.

If I use the IPN simulator in then it says it is sent correctly – but no email, nothing happens.

When I run payments through the website then the payment side of things goes fine, but process_ipn_return is not called.

In my IPN history it is recording that the IPN is being sent, that it is HTTP status 200, the IPN message is all as I would expect, but again no email so the process_ipn_return function is not being called.

On top of all of this I can’t get my return URL to display the contents of the cart – but I’ll get to that once this is fixed.

Any ideas?

  • Elliott Bristow
    • The Bug Hunter

    Hi @kimedia,

    This sounds like a problem with the file that is processing the IPN notification. If pinging the URL directly generates an email, but the IPN simulator doesn’t, perhaps there is a bug in your file that is preventing the IPN from being processed?

    Does the file run any kind of check before sending the mail or is that literally the first line?

    Also, are you absolutely 100% sure the URL is the same in the IPN simulator?

  • kimedia
    • Flash Drive

    Hi Elliot,

    Cheers for the response.

    As it turns out everything is working now (well on that issue anyway)

    for some reason that I am yet to fathom, there was a conflict between me being logged in as an admin and anything at all happening.

    Once I logged out of the account and went through the process as a non logged in user all of my notifications worked.

    Very odd.

    All of my other issues are caused by my own hacking of code. I’m in the process of creating an offshoot to the standard payment gateway so I can bypass having to get people to input shipping info etc.

    As per usual, I spend days working on an issue. Post on a forum and then fix it myself in minutes.

    I should post more often

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.