Can't Get Multi Site functioning properly

I've setup a WP site on GoDaddy using their WP hosting. I've followed the instructions to edit the wp-config and the htaccess files. Everything seems to be working right up to the point that I want to see the new site Dashboard and it goes back to the original site dashboard. I can see the site has been created in the list and under "My Sites" and even get an email confirming it. Any new posts get put in the "home" site.

I imagine I'm missing something obvious. I'm running 4.7.2 and have the WPMUDEV plugin installed.

  • Tyler Postle
    • CGO

    Hey Tom,

    It's not only redirecting the subsite url to your main site it's rewriting it as well. This does sound like it could be a .htaccess issue, would you mind sending in your FTP so we can have a look at both your .htaccess and wp-config? Or just paste them here, but make sure you remove the DB username/password before posting as this is a public forum :slight_smile:

    If you prefer to send it in then you can send that privately through our contact form:

    Send in:

    Subject: "Attn: Tyler Postle"
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    **If you keep support access active then no need to send in wp-admin

    Look forward to hearing back!


  • Tom
    • New Recruit

    Sure, thanks!


    * The base configuration for WordPress
    * The wp-config.php creation script uses this file during the
    * installation. You don't have to use the web site, you can
    * copy this file to "wp-config.php" and fill in the values.
    * This file contains the following configurations:
    * * MySQL settings
    * * Secret keys
    * * Database table prefix
    * * ABSPATH
    * obito
    * @package WordPress

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', '');

    /** MySQL database username */
    define('DB_USER', '');

    /** MySQL database password */
    define('DB_PASSWORD', '');

    /** MySQL hostname */
    define('DB_HOST', '');

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');

    * Authentication Unique Keys and Salts.
    * Change these to different unique phrases!
    * You can generate these using the {obito secret-key service}
    * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
    * @since 2.6.0
    define('AUTH_KEY', '');
    define('SECURE_AUTH_KEY', '');
    define('LOGGED_IN_KEY', '');
    define('NONCE_KEY', '');
    define('AUTH_SALT', '');
    define('SECURE_AUTH_SALT', '');
    define('LOGGED_IN_SALT', '');
    define('NONCE_SALT', '');


    * WordPress Database Table prefix.
    * You can have multiple installations in one database if you give each
    * a unique prefix. Only numbers, letters, and underscores please!
    $table_prefix = '';

    * For developers: WordPress debugging mode.
    * Change this to true to enable the display of notices during development.
    * It is strongly recommended that plugin and theme developers use WP_DEBUG
    * in their development environments.
    * For information on other constants that can be used for debugging,
    * visit the Codex.
    * obito
    define('WP_DEBUG', false);
    //define( 'WP_CACHE', true );
    require_once( dirname( __FILE__ ) . '/gd-config.php' );
    define( 'FS_METHOD', 'direct');
    define('FS_CHMOD_DIR', (0705 & ~ umask()));
    define('FS_CHMOD_FILE', (0604 & ~ umask()));

    define('WP_ALLOW_MULTISITE', true);

    define('MULTISITE', true);
    define('SUBDOMAIN_INSTALL', false);
    define('DOMAIN_CURRENT_SITE', '');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    /* That's all, stop editing! Happy blogging. */

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');


    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    # END WordPress

  • Tyler Postle
    • CGO

    Hey Tom,

    Your .htaccess and wp-config.php looks fine. I do see you mentioned in the email that you changed the url in the db and it worked. I tested a new site to see if the same issue would happen there and it did, unfortunately.

    Investigating this further it looks like GoDaddy Managed WordPress hosting doesn't support Multisite:

    You can see it mentioned in the limitations on that page.

    I'm thinking this is likely the issue as I'm not seeing any problem with your Multisite setup itself. I'd contact them and ask to make sure :slight_smile: hopefully they will have a solution for you to get around it or you may have to switch hosts if you want to use Multisite.

    Let us know if you have further questions on that for us.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.