Can't get Protected Content working

For any reason we don't get our membership settings - using protected content - working.

Below attach several screen shoots to document our troubles which are

1) Signup Form does not link to the right site
2) Adding some custom fields on signup form does not work
3) User Roles are not assigned properly.

What we did so far...

checking out all settings, they are set correctly
resetting buddypress pages... did not solve issue either
resetting permalink did also not work out.

Please help to solve our trouble.
Support access is granted.

Thank you
Prinz

  • Klaus

    Hello Jude,

    thanks for prompt replying. Of course, clearing the cache is always the first step we are doing and we did this for sure several time but with no success.

    Best to view the problem: Go to Homepage... last nav-position JOIN and underneath click various shaped membership level. Then you see first in middle of the screen the indicator to add new member levels.... which is obsolet as we have done that already.

    Click Signup button... you'll be directed to the member site instead to the signup form.

    The other issue is still the one with the avatar... not transferring to sub domain. This was working properly until the wp update to it's newest release. Sometimes when activating Ultimate Branding we get the indicator Blavatar... see screeshoot above.

    Hope that helps.
    Prinz

  • Jude

    Hey Prinz

    Hope you're doing great. I was not able to spot the Blavatar issue. But here are my answers to the others.

    Click Signup button... you'll be directed to the member site instead to the signup form.

    I tried this process, this happens on your user account because you are already a member and administrator. You need to remove construction mode.

    Also you have protected content AND membership installed on the site. They are conflicting plugins please delete Membership PRO. This is why you have a user roles problem.

    I made some changes. Please take a look now .

    Jude

  • Klaus

    Hello Jude,

    now can recognize it too after not logged in as admin. So far okay...

    But, there are still the other hassles left which I can't figure out how to solve. Please be so kind and help further:

    1) Registration Form: If you look precisely, there is the FIRST NAME field missing but, when you look at the form from MY account which is provided by protected content, there is FIRST NAME available.

    2) Checking User PROFILE FIELDS adding a field named FIRST NAME is impossible.

    3) Update a User Profile causes trouble as well. In the COUNTRY field appears the value of FIRST NAME.

    4) Not in CONSTRUCTION MODE going to our site directs straight away to the signup form which is wrong. The entire site should be available for any visitor... then, if a visitor wish to signup he can do so going to the appropriate navigation tab.

    5) The displayed SIGNUP form (not congruent with MY ACCOUNT) includes also the GROUP FIELDS... also ADD NEW MEMBER LEVEL... how to get rid of those entries?

    6) The avatar issue is not solved. Unfortunately your recommendation regards bp-custom.php causes a few addition troubles. In short HOW to get avatars to each domain transferred?

    7) Finally, Membership PRO is interfering obviously Protected Content. BUT in order to run also the AFFILIATE WPMU DEV plugin it is mandatory to have Membership PRO installed. Wondering how get this sorted out?

    Looking forward to your help.
    Kind regards
    Prinz

    NS: Support access is granted

  • Klaus

    Hello Jude,

    probably your to-do list is a very long one and we are anywhere in the queue. On the other hand our issue we filed with this support request is still not resolved since last Saturday.

    Now are really wondering "how do we get shortly a solution"... as we are most concerned that we can't continue with our work.... unfortunately we are far behind of our deadline and our sponsors are going to be impatient.

    Please let us at least know, when can we expect a solution????

    Thanks
    Prinz

  • Jude

    Hi again Prinz,

    Hope you're doing great and thanks for the kind feedback !!

    I am working right now on your solution, I need to check some code on the site before giving you my final answers/solution.

    Can you please send in

    Subject: "Attn: Jude Rosario"
    - WordPress super admin/ admin username + password
    - FTP credentials (host/username/password)
    - cPanel details
    -link back to this thread for reference

    Select "I have a different question" for your topic - this and the subject line ensure that it gets assigned to me :slight_smile:

    https://premium.wpmudev.org/contact/

    Also sorry about the delay. I am working on this immediately and will have this fixed ASAP.

    Jude

  • Klaus

    Hello Jude,
    indeed your support is invaluable. You solved finally the major multi-db trouble we experienced since beginning ... we can't thank you enough for your support.

    We also recognized that you could sort out the protected content issue with the signup form which is great. Meanwhile we checked the settings from protected content, also the add-ons and BuddyPress settings. We truly can state they are ALL identical on main site as well o ALL sub domains.

    Brilliant would be if you can sort out the AVATAR issue too. Please let me know.
    With serious gratitude.
    Prinz

  • Jude

    Hi again @Prinz

    Looks like the registrations were not configured correctly. You had BuddyPress installed and for it to work smooth with Protected Content you need to turn on the add on. I just activated it and now your BP fields you setup will be used for the registration.

    You can use affiliates even with Protected Content as well, so no problem with that.

    About the Avatars issue looks like you do not have server permissions set up correctly. Can you temporarily set the folder permissions to 777 and try again ?

    The issue is that the directory bestofthebestonly.com/avatars needs to be created and given permissions of the web server.

    Also maybe you can try a plugin like this one which we made

    https://premium.wpmudev.org/project/avatars/

    I am putting it back in construction mode. Please confirm if the registration works now.

    Cheers
    Jude

  • Klaus

    Hello Jude,

    permission on directory/avatar folder is set to 777 but unfortunately... AVATARS aren't transferred to sub domains.

    Using suggested PREMIUM/Avatar does not work out either and it has on the installation guide the NOTE that this plugin will NOT work with BuddyPress too.

    Do you have another solution to make this working?

    Looking forward hearing from you again.
    Support access is still granted.

    Regards
    Prinz

  • Klaus

    Hello Jude,

    with utmost respect we strongly believe your are most busy and that's why you don't respond to the AVATAR issue anymore.

    We need to progress urgently but this matter blocks us from do our work. Therefore please let us at least know

    - you are still working on it and we can expect shortly a solution...?
    - perhaps you forwarded this case to another supporter but we aren't informed about it...?
    - should we close this support request and file another one to get this huge problem solved...?

    Looking forward hearing from you shortly about the next step.
    Thank you
    Prinz

  • Klaus

    Hello Jude,

    thanks for letting me know. Well, we do understand hasty changes causes usually more troubles. On the other hand we are most concerned about our delay as we are waiting for a solution since two week by now. Also we recognized there were on support staff login to our server since days.

    Do you believe we you'll have fixed the problem by the end of today?

    Big thanks in advance.
    Prinz

  • Jude

    Hey Prinz

    So sorry about delay in response. I have a few fixes to this problem which I'd like you to take a backup and try

    Just copy/paste the code into the functions.php file of your child theme or a site specific plugin if you use one.

    function botbo_bp_avtar_upload_path_correct($path){
    	if ( bp_core_is_multisite() ){
    		$path = ABSPATH . get_blog_option( BP_ROOT_BLOG, 'upload_path' );
    	}
    	return $path;
    }
    add_filter('bp_core_avatar_upload_path', 'botbo_bp_avtar_upload_path_correct', 1);
    
    function botbo_bp_avatar_upload_url_correct($url){
    	if ( bp_core_is_multisite() ){
    		$url = get_blog_option( BP_ROOT_BLOG, 'siteurl' ) . "/wp-content/uploads/";
    	}
    	return $url;
    }
    add_filter('bp_core_avatar_url', 'botbo_bp_avatar_upload_url_correct', 1);

    Also please add this to you're wp-config.php file

    define( 'BP_AVATAR_UPLOAD_PATH', '/var/www/html/example/wp-content/uploads' );
    define( 'BP_AVATAR_URL', 'http://example.com/wp-content/uploads' );
    define( 'BP_ROOT_BLOG', '1' );

    Please replace with you're correct urls on the site.

    Actually we cannot do much with support access here, we need FTP access that's why you were not able to spot staff logins.

    Just explaining the change
    We are overriding the paths using functions and defining the constants manually. This should hopefully fix the issue.

    Please let me know if this does not work, I'll escalate the issue and get some experienced dev to look in.

    Jude

  • Klaus

    Hello Jude,

    am really pleased knowing you most reliable supporter and most grateful that you took on our Avatar issue.

    Before we do wrong please let me know are the replacements correct?

    define( 'BP_AVATAR_UPLOAD_PATH', '/var/www/html/bestofthebestonly.com/wp-content/uploads' );
    define( 'BP_AVATAR_URL', 'http://www.bestofthebestonly.com/wp-content/uploads' );
    define( 'BP_ROOT_BLOG', '1' );

    Also,
    what it there is no function.php file in the theme-child folder?

    Cheers
    Prinz

  • Jude

    Hey Prinz

    That's ok, I have BlueHost details from before which Im using. Looks like the first option I suggested in your old thread may have not been done correctly. You created a folder called /YOUR_ABSOLUTE_PATH_TO_YOUR_OLD_BP_LOCATION , I meant to use the folder location instead. Anyhoo no worries we can try again.

    1) Anyway please take a backup.
    2) Also tell me where is the folder with the old avatars ? I will manually move it or write a script and move it.
    3) Don't try the above steps, I'll do it for you myself.

    5) Give me an example where the site AVATAR is broken / not working so I can check once the work is done.

    Jude

  • Klaus

    Hello Jude,

    in response ...

    1) backup is done
    2) have no clue where avatar folder is placed but when you open the public_html there you'll find an avatar folder. however it looks like that this is a new one.... created just yesterday perhaps from you.
    3) promised to avoid wrong doing I am more than happy to let you do what's needed to be done

    4) Avatar only works on main domain http://www.bestofthebestonly.com but it doesn't work on any sub domains which are listed here http://www.bestofthebestonly.com/wp-admin/network/sites.php

    Hope that helps.
    Looking forward to your reply gratefully
    Prinz

  • Jude

    Sorry about the extreme delay here. The issue was the instructions in my previous thread were not carried out correctly. Im not blaming you .. we love you as our valued member. Just that I should have checked that first, but missed it.

    For anyone else reading this follow the steps listed here.

    Add the following to wp-config.php

    define ( 'BP_ROOT_BLOG', $blog_id );
    define( 'BP_AVATAR_UPLOAD_PATH', 'YOUR_ABSOLUTE_PATH_TO_YOUR_OLD_BP_LOCATION' );
    define( 'BP_AVATAR_URL', 'YOUR OLD BUDDYPRESS URL' );

    Please confirm its working now :slight_smile:

    Cheers
    Jude

  • Klaus

    Hello Jude,

    indeed it works! What a brilliant moment...

    Now, isn't it sad that all those reading this support request don't recognize how much effort... how complex both issues in this listing it really was?

    However we are aware and we really do recognize all the efforts and time you put into this issue and we can't thank you enough for that. Your excellent support is outstanding!

    Gratefully
    Prinz

  • Jude

    Hey Prinz

    Thanks for confirming :slight_smile:

    Now, isn't it sad that all those reading this support request don't recognize how much effort... how complex both issues in this listing it really was?

    That's Ok, I was more concerned that it was getting delayed for you, but could not give you a valid solution. Only when I took a step back forgot everything and treated it like a fresh ticket finally my brain clicked.

    Anyway Im posting this here to tell you to move your wp-config.php entries along with your site during migration otherwise if you move again the avatars may stop working.

    Take care
    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.