can't get the comment plus plugin to work, tried the things I could find in this forum.

http://www.reearth.com, using BuddyPress Daily theme, deactivated all plugins and tested, no luck. maybe someone can give me a hint what the problem can be? also have the ultimate facebook plugin installed but it does not work proper either. maybe the same problem?

  • DavidM

    Hi reearth,

    In testing BP Daily with Comments Plus, I'm able to see the comments section. But it seems you've got quite a lot of customizations in your child theme there.

    If you take a look at your comments.php file, do you see the following anywhere in there?
    comment_form()

    EDIT: I ask that because the line is in the original theme's comments.php file and I believe that's what is allowing Comments Plus to do its job.

    Thanks,
    David

  • roeder

    hi..i also installed comments plus in overeasy theme from woothemes but it's not showing up..
    this is the code in the comments.php file:

    <?php
    // Do not delete these lines
    	if (!empty($_SERVER['SCRIPT_FILENAME']) && 'comments.php' == basename($_SERVER['SCRIPT_FILENAME']))
    		die ('Please do not load this page directly. Thanks!');
    
    	if ( post_password_required() ) { ?>
    		<p class="nocomments"><?php _e('This post is password protected. Enter the password to view comments', 'woothemes' ); ?>.</p>
    	<?php
    		return;
    	}
    ?>
    
    <!-- You can start editing here. -->
    
    <div id="comments_wrap">
    
    <?php if ( have_comments() ) : ?>
    
    	<h3><?php comments_number(__('No Responses', 'woothemes' ), __('One Response', 'woothemes' ), __('% Responses', 'woothemes' ) );?> <?php _e('to', 'woothemes' ); ?> “<?php the_title(); ?>”</h3>
    
    	<ol class="commentlist">
    	<?php wp_list_comments('avatar_size=48&callback=custom_comment'); ?>
    	</ol>    
    
    	<div class="navigation">
    		<div class="alignleft"><?php previous_comments_link() ?></div>
    		<div class="alignright"><?php next_comments_link() ?></div>
    		<div class="fix"></div>
    	</div>
    	<br />
    	<?php if ( $comments_by_type['pings'] ) : ?>
        <h2 id="pings"><?php _e('Trackbacks/Pingbacks', 'woothemes' ); ?></h3>
        <ol class="commentlist">
        <?php wp_list_comments('type=pings'); ?>
        </ol>
        <?php endif; ?>
    
    <?php else : // this is displayed if there are no comments so far ?>
    
    	<?php if ('open' == $post->comment_status) : ?>
    		<!-- If comments are open, but there are no comments. -->
    
    	 <?php else : // comments are closed ?>
    		<!-- If comments are closed. -->
    		<p class="nocomments"><?php _e('Comments are closed.', 'woothemes' ); ?></p>
    
    	<?php endif; ?>
    
    <?php endif; ?>
    
    </div> <!-- end #comments_wrap -->
    
    <?php if ('open' == $post->comment_status) : ?>
    
    <div id="respond">
    
    <h3><?php comment_form_title( __('Leave a Reply', 'woothemes' ), __('Leave a Reply to %s', 'woothemes' ) ); ?></h3>
    <div class="cancel-comment-reply">
    	<small><?php cancel_comment_reply_link( __( 'Click here to cancel reply.', 'woothemes' ) ); ?></small>
    </div>
    
    <?php if ( get_option('comment_registration') && !$user_ID ) : ?>
    
    <p><?php _e('You must be', 'woothemes' ); ?> <a href="<?php echo get_option('siteurl'); ?>/wp-login.php?redirect_to=<?php echo urlencode(get_permalink()); ?>"><?php _e('logged in', 'woothemes' ); ?></a> <?php _e('to post a comment.', 'woothemes' ); ?></p>
    
    <?php else : ?>
    <form action="<?php echo get_option('siteurl'); ?>/wp-comments-post.php" method="post" id="commentform">
    <fieldset class="form1">
    
    <?php if ( $user_ID ) : ?>
    
    <p><?php _e('Logged in as', 'woothemes' ); ?> <a href="<?php echo get_option('siteurl'); ?>/wp-admin/profile.php"><?php echo $user_identity; ?></a>. <a href="<?php echo wp_logout_url(); ?>" title="<?php _e('Log out of this account', 'woothemes' ); ?>"><?php _e('Logout &raquo;', 'woothemes' ); ?></a></p>
    
    <?php else : ?>
    
    <p style="padding:5px 0px 10px 0px;"><input type="text" name="author" id="author" value="<?php echo $comment_author; ?>" size="22" tabindex="1" />
    <label for="author"><?php _e('Name', 'woothemes' ); ?> <?php if ($req) _e( '(required)', 'woothemes' ); ?></label></p>
    
    <p style="padding:5px 0px 10px 0px;"><input type="text" name="email" id="email" value="<?php echo $comment_author_email; ?>" size="22" tabindex="2" />
    <label for="email"><?php _e('Mail (will not be published)', 'woothemes' ); ?> <?php if ($req)  _e( '(required)', 'woothemes' ); ?></label></p>
    
    <p style="padding:5px 0px 10px 0px;"><input type="text" name="url" id="url" value="<?php echo $comment_author_url; ?>" size="22" tabindex="3" />
    <label for="url"><?php _e('Website', 'woothemes' ); ?></label></p>
    
    <?php endif; ?>
    
    <p><textarea name="comment" id="comment" cols="50" rows="15" tabindex="4" style="width:97%"></textarea></p>
    
    <p><input name="submit" type="submit" class="btn" tabindex="5" value="<?php _e('Submit Comment', 'woothemes' ); ?>" />
    <input type="hidden" name="comment_post_ID" value="<?php echo $id; ?>" />
    </p><?php comment_id_fields(); ?>
    <?php do_action('comment_form', $post->ID); ?>
        </fieldset>
    
    </form>
    
    <?php endif; // If logged in ?>
    
    <div class="fix"></div>
    </div> <!-- end #respond -->
    
    <?php endif; // if you delete this the sky will fall on your head ?>
  • roeder

    awesome thanks..it's showing up now..
    my next problem is the twitter authentication error when i try to sign-in with twitter..
    i already entered the callback url..and the consumer key and secret..and set access level to read & write

    Woah there!

    This page is no longer valid. It looks like someone already used the token information you provided. Please return to the site that sent you to this page and try again … it was probably an honest mistake.

    and when i comment in default wordpress box it just goes to http://site.com/wp-comments-post.php and it's blank

  • Mason

    Hiya Tourika,

    Welcome to WPMU DEV!

    For future reference, old threads like this that are marked 'resolved' are often overlooked. It's much better to start your own thread on an issue or 're-open' a thread to let us know.

    At any rate, it looks like you have an issue with multiple loadings of the facebook/twitter javascripts. You can either disable the other social media plugins on your site or try selecting "Skip loading Facebook javascript" and "Skip loading Twitter javascript" in the Comments+ plugin.

    Let us know how it goes!

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.