Cant get Ultimate Facebook to work

I cant seem to get ultimate facebook to work. I have set up the api properly because it is working on a next site I have. my url is dearfinder.com. when i try to login, facebook login comes up, but after entering my credentials nothing happens.

  • Sajid
    • DEV MAN’s Sidekick

    Hi @gregory,

    Hope you are doing good today :slight_smile:

    You said your APP is working on other site. As far as I know you need to create separate APP to be used for each of your site. Its not a plugin restriction but Facebook does not allows an APP to be used on multiple domains.

    Please create another Facebook APP for this domain and then check again.

    Hope that helps! Feel free to post a reply if you need further assistance :slight_smile:

    Cheers, Sajid

  • gregory
    • Design Lord, Child of Thor

    Thanks for your reply. It is a multisite installed. The issue is after facebook login screen is launched, nothing happens, the facebook lock looks to work, but there is no login on the site. Just check the site for me please.

  • Nastia
    • Support Rock Star

    Hello @gregory, I trust you are doing well today!

    I've logged in to your site, created a new Facebook API and could not login again with Facebook Login button.

    While I was on the login page, there was an js error in the developer console:
    Uncaught ReferenceError: _wdfb_notifyAndRedirect is not defined

    Just to exclude most common reason of this issue, would you please disable all other plugins and test again? And please switch to the WordPress default theme and test again. If the issue is gone, please activate one plugin at the time to find out which one is causing this conflict.

    Please follow the flowchart from our manual:
    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    In case if after disabling all the plugins and switching to a default theme the login button is still not working, please enable WordPress debugging. Put the following code in to the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Once you enable debugging, try to login again, and all errors will be saved to a debug.log log file inside the /wp-content/ directory. Please attache this file here.

    We'll be awaiting for your reply!

    Cheers,
    Nastia

  • Sajid
    • DEV MAN’s Sidekick

    Hi @gregory,

    Hope you are doing good today :slight_smile:

    I can see you have enabled it for network wide. Did you tested it by activating on main site only ? If no then please activate on individual main site only and then check.

    Look forward towards your response @gregory :slight_smile:

    Cheers, Sajid

  • gregory
    • Design Lord, Child of Thor

    Thanks for your response.

    I was referring to website http://smartstopshopping.com/ as it only have three plugins word fence, wpmdev dashboard, ultimate Facebook installed and is using the default WordPress theme 2016. So I would have activated on this site and this is a main site, but am still getting the error: User registration is currently not allowed. I can enable support access.

  • gregory
    • Design Lord, Child of Thor

    I would really like this issue to be be resolve as I am at a stop still right now. I know my api is working because I was able to successfully log in using a different facebook plugin option. I have also disable all plugins and load the default wordpress theme and I still have the issue. I have tested it on a new site that is free from other plugins except wpmudev dashboard and still getting the error: User registration is currently not allowed. I have checked to make sure that anyone can register is enable. So I leaning towards to issue with the plugin itself. I am able to share, like using the plugin, but I cant login and thats the issue. Can anyone help me out.

    This is second site http://smartstopshopping.com/ I have, if the issue is solve there I think it will be solve on http://dearfinder.com/.

    I have gone ahead and grand access.

  • Nastia
    • Support Rock Star

    Hello @gregory, I trust you are doing well today!

    Would you please send to us your credentials so we could troubleshoot it upclose?

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/

    - Mark to my attention, the subject line should contain only: ATTN: Anastasia
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    Select “I have a different question” for your topic
    https://premium.wpmudev.org/contact/

  • Nastia
    • Support Rock Star

    Hello Gregory!

    I hope you are well!

    I didn't receive your credentials yet. Would you please resend them again? The subject line should contain only: ATTN: Anastasia
    And include in the main email body this information:
    -WordPress admin username
    -WordPress admin password
    -login url
    -FTP credentials (host/username/password)
    -link back to this thread for reference
    -any other relevant urls

    You can send credentials by using our secure contact form https://premium.wpmudev.org/contact/
    or email us directly to contact@wpmudev.org.

    Kind Regards,
    Nastia

  • gregory
    • Design Lord, Child of Thor

    Hello am still awaiting a response, as to the progress of resolving this issue. I have send the require information and I have not gotten back any response as yet.

    I have tested the same credentials on a theme that has Facebook login implemented and I don't have a issue logging in.

    I have read other support forums on wpmudev which supports the notion that the plugin has some faults.

    I am at a standstill as it stands right now, as I don't know if this issue will be resolve.

    I am still awaiting, and I hope the team at wpmudev can come through as they always do.

    Thanks

  • Nastia
    • Support Rock Star

    Hello @nugregorybro, I hope you are doing well today!

    My sincerest apologies for the delayed response.

    I was trying log in to your main website but the password is incorrect, plus my IP was blocked by WordFence.

    The Facebook login button on your test site is working now. In Facebook Settings > Facebook Connect section the "Allow single-click registration" option was unchecked. Once the option is checked, the Facebook login button allowed one click registration and login.

    Please make sure that you have "Allow single-click registration" option checked on your main site. Otherwise, if this will not solve the issue, please resend the correct credentials using our contact page.

    Please advise,

    Kind Regards,
    Cheers

  • Nastia
    • Support Rock Star

    Hello Gregory,

    Thank you for resending your credentials. I have informed the developer about this issue.

    In the meanwhile please try the following solution provided from a developer:
    Follow these steps :
    - go to FB account settings page, add a new email under "general / email" and make it primary.
    - make the previous email primary again and delete the added email so the configuration stay the same.

    Let us know how it went!

    Cheers,
    Nastia

  • Nastia
    • Support Rock Star

    Hello @Gregory!

    It turns out a bug. Me and my colleague Sajid could not replicate it at first because we have setup the Facebook API from a while ago, so it was working on our sites. Once I reseted the plugin I could replicate the issue. Our developers already familiar with this issue and they are looking for a solution. As soon as there’s an update on this issue, the developer or myself will post back on this thread with an update.

    Thank you for your patience!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.