Can't install additional plugins

I've been having a problem installing the additional plugins it just comes up with an ! and retry has the same result. Can you help me with this?